Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Cinemike

Pages: [1] 2 3 ... 53
1
You would never use metalness except for metals, so not at all on wood :) )
Not even for the wood of the silver birch?
*Running away and laughing madly*

2
[C4D] Daily Builds / Re: Version R16
« on: 2021-10-08, 23:39:14 »
Hello,
@Cinemike: Corona does have it's own menu (this is probably corona versioned rather than cinema versioned)

True, checked with the latest version now, Corona is there as you said. I still had a Corona version from 2015 in my R16 installation which was in the plugins menu.

3
[C4D] Daily Builds / Re: Version R16
« on: 2021-10-08, 09:05:17 »
If I remember correctly, Corona render did not have its own menu in the top bar. You can find it under "Plugins".

4
[C4D] Feature Requests / Re: Sun Exclusion Tolerance
« on: 2021-10-07, 19:17:39 »
It's not a perfect workaround (cue: shadows), but you could use two suns. One main sun that "excludes" the specific object and a second sun that only includes this specific object and shines with 20% of the main sun's intensity.

This was indeed a good solution for my issue! Thanks again

:)

5
[C4D] General Discussion / Re: Plants in Corona
« on: 2021-10-02, 19:53:34 »
I am afraid you cheated ^^
Accidentally. Unintentionally ;)

From the 4 maple trees from the asset browser, two come with non-layer color textures, these work and don't render black, The other two don't.

And then there's the alpha layer assignment issue (that sometimes hits).

CU
Michael

6
When a native C4D material contains a layer shader, this layer shader is rendered black, no matter what it contains.
This is probably also the reason why a converted C4D material that contains a layer shader will end up as a Corona material with an empty layer shader.

Also take a look at "Mat" (the leaves material). Although everything looks fine (in the preview and also in the black and white texture representation of the texture in the alpha channel), obviously the wrong layer set is used. Just open the "choose layer set" setting to check.

7
[C4D] General Discussion / Re: Plants in Corona
« on: 2021-10-02, 13:02:20 »
I strongly advise against using unconverted tree materials.
Left: The tree with C4D materials "as is".
Right: Basic conversion done (no adaption or extras yet).

You'd still have to adapt the alpha layer in the native material and the layer shader in "Color" is not rendered correctly either. So you better convert manually to proper Corona materials and save your work. It's a few minutes per plant/tree and worth the effort.


8
[C4D] General Discussion / Re: Plants in Corona
« on: 2021-09-29, 22:24:13 »
Let me give you an example.

Load the cherry tree model from the content browser / asset browser (depending on what version of C4D you have). It comes with a material for the bark and another one for the leaves. Copy both materials (Edit/Copy in the Material Manager).

Now go to the Corona menu and execute "Convert Scene...". This command does exactly what it says, it converts the C4D materials to Corona materials. But these materials need some work.
Let's start with the bark. Here, the conversion ran almost perfectly. You just need to adjust the glossiness value of 50% to something less wet, like 20%. But that's up to you.

Now to the leaves. Here we will have to do a little more work.

Let's start in the base layer. First thing we notice is a black "Layer" texture. When we open it, it's empty. The Corona material converter has been screwing up C4D layer shaders as long as I can remember. I hope this gets fixed one day. Until then there's a "workaround". We did not copy the original materials for nothing! So it is time to "Edit/Paste" them.
Now that we have the original materials back, we open the C4D leaf material and "copy shader" the intact layer from there and paste it in our Corona material.

The bump channel was converted correctly, we leave it as it is.

The last thing we need to adjust is the opacity. We go to the opacity channel, click on the texture and then click on "Layer Set / Select". We need the alpha channel of the texture, so check that box and click "Ok".

As a bonus, we can now add Translucency, which will often improve the realism of a plant rendering greatly.
Go the the General channel and check "Thin Shell". Now we can activate "Translucency". Increase "Value" to 50%. Copy the color texture from the base layer (it should even still be in our copy buffer) and paste it in the Color texture slot of "Translucency". I often add a little yellow to the texture here, but that's up to you, as much as tweaking any other setting along the way.

Hope this helps.
Michael

9
[C4D] Feature Requests / Re: Sun Exclusion Tolerance
« on: 2021-09-22, 22:37:19 »
It's not a perfect workaround (cue: shadows), but you could use two suns. One main sun that "excludes" the specific object and a second sun that only includes this specific object and shines with 20% of the main sun's intensity.

10
[C4D] General Discussion / Re: C4D R25 & Corona
« on: 2021-09-17, 15:46:58 »
Is it v7 we shall wait for or is it v8? I want to try the new C4D 25 version :)
Don't forget you can have V7 for S24 and V8 for R25, so there is absolutely no risk in trying.

11
[C4D] Bug Reporting / Re: Cinema4D R25 and Corona Renderer
« on: 2021-09-14, 20:16:17 »
Every single C++ plugin needs a re-compile to work with R25.
So does Corona.

12
I don't think it's crazy geometry, just too much of sane one :)

13
you wont like this lol, but i dont use node textures. I use the basic material editor.

So?

14
Are you possibly running out of free RAM?
Other than that, I suppose the support would need your scene to know more.


General questions:
- Could it be that Cinema R21 and Corona 5 are too "old" to do the job…and I should update it?


Corona 5 is not too old, but I still would use a recent version, because many bugs were fixed and they render faster due to many optimisations.
Give it a try, you can always go back, just in case.

CU
Michael

15
[C4D] I need help! / Re: rigged person / motion blur
« on: 2021-08-29, 14:25:28 »
Your animated person is not actually moving (the object itself stays put in the same place), it is just its mesh that is deforming along the way.
Unfortunately, Corona for C4D does not yet support object deformation and motion blur, this planned in a version past V8 (according to the roadmap), although I hope it gets addressed earlier.

Michael

Pages: [1] 2 3 ... 53