Author Topic: Fog in Scenes  (Read 484 times)

2023-08-10, 10:39:33

wardy_mk

  • Active Users
  • **
  • Posts: 56
    • View Profile
Hello. Just trying to teach myself a few things here. I'm trying to achieve a 'fog' effect.
I have a scene where I have a Corona Sky. Within it is a "Shanghai at night" HDR. This provides the illumination and a background for the image.
To create the fog I created a Volume Material and messed around with some of the variables until I was happy. Then I have gone into the render settings and gone into "Scene Environment", then dropped the new material into the "Global Volume". See attached for the material settings etc.
The density, etc is all great. However, The fog is very 'grainy'. Upping the passes from 20 to much higher doesn't seem to fix this.
I'm sure there's a slider somewhere to increase samples or something but can you please show me what I need to do?
Attached are the settings for the material. I've also attached a screen grab of a 'grainy' area...
Thanks in advance


2023-08-10, 15:10:41
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12660
  • Marcin
    • View Profile
Enable "single bounce only" in your volume material - this will make it render MUCH faster. :)

As to render settings, usually what you see inside the Volume Mtl is light cast by other objects, so increasing Light Samples Multiplier might help (from the default 2 to something like 4, but probably no more).
Also note that to get good quality image you need to render about 100 passes, and in some cases even more may be needed.
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us

2023-08-14, 09:43:04
Reply #2

wardy_mk

  • Active Users
  • **
  • Posts: 56
    • View Profile
Thanks for the reply. I did notice that the amount of passes didn't seem to affect the quality to I assume the problem lies within the 'light samples' you've mentioned.
I'll have a further look! Thanks :)