Author Topic: Corona Volume Grid  (Read 1247 times)

2021-09-14, 15:30:06

mte

  • Active Users
  • **
  • Posts: 75
    • View Profile
Hi,

I stumbled over a nasty bug when working with vdbs.
the Corona Volume Grid object changes the file path to the .VDB when saving the project using "save with assets".
This way it is almost impossible to render vdbs on a render farm.
It would be better if you did not change the file path in any means. Just leave it and let the user take care of relative or absolute paths.
The second problem is, that the emission, absorbtion, scattering, settings are reset to default, when no vdb is found. Unfortunately this is always the case when opening the saved scene, because of the previous path changes.

It would be great if you could have a look.
thanks
moosi

2021-09-14, 16:09:01
Reply #1

Beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 2085
  • Bengamin
    • View Profile
    • Cormats
I removed my comment because unfortunately, I read your question wrong and the answer would not be of any use. We will look into this further and let you know our findings.

2021-09-14, 16:27:26
Reply #2

Beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 2085
  • Bengamin
    • View Profile
    • Cormats
After some further tests, we also agree that this is incorrect and it has been logged internally. Thanks for bringing it to our attention.

For internal use: (Internal ID=756278333)

2021-09-14, 17:03:58
Reply #3

mte

  • Active Users
  • **
  • Posts: 75
    • View Profile
oh, that was fast. :-)
thanks a lot

2021-09-15, 11:08:52
Reply #4

mte

  • Active Users
  • **
  • Posts: 75
    • View Profile
Hey,
there is another issue with the Volume Grid and renderfarms.
Logically, a render farm separates all images into individual chunks and let each node render some frames. Node1 is rendering frame 0-5, node2: 6-10 an so on.
The problem is, that the Volume Grid is loading the VDBs in some sort of lazy-loading. That leads to the problem that the node starts rendering, but the VDBs are not loaded. The result is always that the first frame is rendered without VDB. In this example it is frame 0, 6, 11...
The Corona Volume Grid should prevent the node from rendering until all is loaded.

2021-12-01, 01:19:31
Reply #5

Sergiy Lysenko

  • Users
  • *
  • Posts: 3
    • View Profile
Dear developers,

I've stuck on the same issue -  saved project with an assets, prepared to send it to the farm - but my Volume Grid is empty. I have relinked them, saved the file again - its again empty after reopening.

I was working with V7 Hotfix1, installed Hotfix2 - nothing changed.

Do you have any solution how to fix it?

Thank you!

2021-12-02, 10:42:47
Reply #6

mmarcotic

  • Corona Team
  • Active Users
  • ****
  • Posts: 492
  • Jan - C4D QA
    • View Profile
Hello,

are you referencing the vdb files relatively or with an absolute path?

Thanks,
Jan
Learn how to report bugs for Corona in C4D here.

Yesterday at 10:04:23
Reply #7

Sergiy Lysenko

  • Users
  • *
  • Posts: 3
    • View Profile
Jan, could you please explain where should I check relative or an absolute path?

To fix the problem I was forced to create a new Volume Grid object, insert VDB there, delete an old Volume Grid object (the one which existed before "Saving file with Assets").

But seems like it does not work for render farms anyway. I did a quick test yesterday with a GarageFarm and there is NO vdb in my render. Meanwhile there is Volume folder with vdb files in their Scene Files manager.
« Last Edit: Yesterday at 13:02:45 by Sergiy Lysenko »

Yesterday at 13:00:03
Reply #8

mte

  • Active Users
  • **
  • Posts: 75
    • View Profile
Hello,

are you referencing the vdb files relatively or with an absolute path?

Thanks,
Jan

Hi Jan,
the problem is not an relative or absolute path. The problem is that the VDB object messes around with the path while using the "save with assets" option.
In my opinion, the best way to solve the bug would be to absolutely not try to alter the path by any means. Just leave it alone.
« Last Edit: Yesterday at 13:10:56 by mte »