Author Topic: Crash with animated Particle object used in a Mesher Compound object  (Read 2067 times)

2020-04-22, 22:51:41

pokoy

  • Active Users
  • **
  • Posts: 1527
    • View Profile
I'm using the Mesher Compound object on a particle system SuperSpray object. The Mesher Compound useful when you want to use geometry based modifiers or a Corona displacement modifier on a particle system since you can't do this directly on any particle object.
Rendering works fine until geometry motion blur is enabled - in this case, Corona will hang while parsing the scene and eventually crash to desktop. Unfortunately no minidump is created.

I tested Mesher with standard animated geometry and it works fine. It looks like it's happening on particle systems only.
Is there anything that can be done about it?

Attaching a scene - Max 2020, Corona v5

To repro:
- open the scene, the layer '01_Mesher_Standard_Geometry' is visible
- render
>>> all works, motion blur works on the sphere with animated noise and the mesher object

- unhide the layer '02_Mesher_Particle_Object'
- render
>>> Corona will hang/freeze and eventually crash to desktop.

Note that if you disable motion blur in the camera it works fine.
The offending object is colored red in the viewport ;)

Additional note - it looks like the particle spray is causing problems and leads to crashes even if no mesher object is visible. If you make the motion blur to last longer - 1s for example - Max will eventually crash when scrubbing the timeline and forcing it to update while in IR. This time it crashes with the CER dialog. Attaching the minidump from that crash, too.

2020-06-12, 14:04:33
Reply #1

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 915
    • View Profile
Hi Pokoy,

Thanks for reporting this, I have been able to reproduce it with your scene. I will forward this to the dev team for further investigation.

Thanks,

Rowan

(Internal ID=520288616)
Please read this before reporting bugs:
How to report issues to us!

2020-06-12, 14:27:14
Reply #2

pokoy

  • Active Users
  • **
  • Posts: 1527
    • View Profile

2020-08-19, 17:33:51
Reply #3

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 915
    • View Profile
Hi,

The crash during production rendering is fixed in v6 RC3, unfortunately the crash while scrubbing the timeline during iR turned out to be a seperate issue, so this is not yet fixed.

Cheers,

Rowan
Please read this before reporting bugs:
How to report issues to us!

2020-08-19, 19:25:30
Reply #4

pokoy

  • Active Users
  • **
  • Posts: 1527
    • View Profile

2020-08-21, 20:58:25
Reply #5

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 915
    • View Profile
Hi,

We fixed the crash when scrubbing the timeline in RC4 :)

Let me know if you have any issues.

Cheers,

Rowan
Please read this before reporting bugs:
How to report issues to us!

2020-08-22, 23:19:29
Reply #6

pokoy

  • Active Users
  • **
  • Posts: 1527
    • View Profile