Author Topic: Volumetric Fog in C4D (not mist)  (Read 883 times)

2020-01-17, 05:55:29

caspian

  • Active Users
  • **
  • Posts: 13
    • View Profile
https://www.stateofartacademy.com/en/corona-renderer-tutorial-volumetric-fog/

I thought I understood the basics of volumetric fog, but I can't seems to achieve this effect (link above) that has different densities, rather than a more general mist in C4D. With my limited knowledge I thought putting a noise shader in the volume would be good place to start, but it just makes things blotchy and just looks rubbish. Any ideas greatly appreciated!

2020-01-17, 14:20:06
Reply #1

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3317
    • View Profile
You need to use the Volume material, and you need to swap it to Inside Volume mode (rather than the default On Surface mode). A screen grab of your material set up would help, to see just how you have things set up just now :)

2020-01-17, 20:10:33
Reply #2

caspian

  • Active Users
  • **
  • Posts: 13
    • View Profile
My material here (includes what I am trying to achieve:https://imgur.com/a/KvAVHlX

thanks!

2020-01-17, 20:14:20
Reply #3

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3317
    • View Profile
With the right noise map that should work just fine :) The noise will have to be in 3D and not in 2D (e.g. UV space). The noise would go into the absorption and/or scattering.

2020-01-20, 13:58:12
Reply #4

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1743
  • Bengamin
    • View Profile
    • Cormats
Hi Caspian, here's a quick setup that might get you in the right direction. You should be able to control the falloff by tweaking the gradient sliders. With turbulence added to the gradient it will make the falloff not so uniform. I hope that helps.


2020-01-20, 14:30:34
Reply #5

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3317
    • View Profile
As a note, there's a report of a possible bug, see https://forum.corona-renderer.com/index.php?topic=27614

caspian, if you can confirm which version of Corona you are using, and maybe upload a scene with the material (can be just a cube and the problem material) as that would let us look into your scene while checking the other one. Thanks!

2020-01-20, 18:19:09
Reply #6

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3317
    • View Profile
Ok, that bug report has been checked, and it wasn't using a 3D space for the Noise shaders (World, or Object), but was using Texture. This incorrectly worked in earlier versions of Corona.

So, if you have the Noise set to some 3D mapping and are still having problems, it would help if you could send us the scene :) Thanks!

2020-01-22, 01:35:51
Reply #7

caspian

  • Active Users
  • **
  • Posts: 13
    • View Profile
Thank you all for you help. I'm testing it with the 3D noise material beanzvision posted. (it certainly slows render time!)
I am trying to summarise what each of Absorption, Scattering Emission do in my notes so I don't forget and just end up pushing sliders:
I'm a little confused between the distance setting in Absorption and Emission, and what the Step size (Volume mapping) does.

Is there a help/index I can search for?

2020-01-22, 07:52:40
Reply #8

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3317
    • View Profile
Since the parameters work the same way whether inside mode is enabled or on surface mode is used, check https://help.c4d.corona-renderer.com/support/solutions/articles/12000035577-how-to-use-volumetrics-

Also the 3ds Max volume tutorials will cover the same topics in video form -
,
etc.

2020-01-22, 07:53:43
Reply #9

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3317
    • View Profile
The one thing specific to inside mode is step size - the smaller the step size, the more accurate the result but the longer the render time. Best to find the highest step size where you don't see "boxy" artifacts in the result, as that will give the best render time possible without losing quality.