Author Topic: Lights through glass displaying black  (Read 1109 times)

2019-04-23, 13:07:55

Jpjapers

  • Active Users
  • **
  • Posts: 1365
    • View Profile
Havent seen this in a few versions. Lights showing through glass as black discs?
max 2018, corona 3 with standard glass shader+ absorbtion colour.

2019-04-23, 16:09:11
Reply #1

dzintas

  • Active Users
  • **
  • Posts: 26
    • View Profile
Usually this happens when you uncheck "visible in refractions" checkbox.

2019-04-24, 10:13:12
Reply #2

Jpjapers

  • Active Users
  • **
  • Posts: 1365
    • View Profile
Usually this happens when you uncheck "visible in refractions" checkbox.

Yes but in this instance that box is checked.

2019-04-24, 14:14:36
Reply #3

alexyork

  • Active Users
  • **
  • Posts: 565
  • Partner at Recent Spaces
    • View Profile
    • RECENT SPACES
I've also had this lately using a recent v4 DB although can't compare in v3/v2 for now. same kind of set up. super simple thick glass screen with a simple disc corona light visible through it - renders black. when you don't look through the glass it renders white. visible to refraction/reflection + visible in render all turned on, incl. prevent black appearance.
Alex York
Partner
RECENT SPACES
recentspaces.com

2019-04-24, 15:25:16
Reply #4

Jpjapers

  • Active Users
  • **
  • Posts: 1365
    • View Profile
I've also had this lately using a recent v4 DB although can't compare in v3/v2 for now. same kind of set up. super simple thick glass screen with a simple disc corona light visible through it - renders black. when you don't look through the glass it renders white. visible to refraction/reflection + visible in render all turned on, incl. prevent black appearance.

Yeah same exact setup it seems. I havent tried any dailies.
Ill experiment and see if i can find any cause.

2019-04-30, 16:58:51
Reply #5

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10186
  • Marcin
    • View Profile

2020-04-01, 14:13:06
Reply #6

sprayer

  • Active Users
  • **
  • Posts: 780
    • View Profile

In v5 still this problem exist
Is there any workaround? I can't turning off refraction for frosted glass =(

it seams this happens for ies light
« Last Edit: 2020-04-01, 16:46:40 by sprayer »

2020-04-01, 16:52:37
Reply #7

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10186
  • Marcin
    • View Profile
The workaround is to use two separate objects for lights:
1. The visible part, which will be visible directly, in reflections, in refractions - it does not emit light, but it is visible. Example: LightMtl with "emit light" off; rayswitch
2. The invisible part, which casts light into the scene - e.g. a Corona Light set to fully invisible

The issue here is that the "prevent black" option only works for direct visibility (not for reflections and refractions). We know about it and want to provide a fix as soon as possible.

2020-04-01, 17:28:02
Reply #8

sprayer

  • Active Users
  • **
  • Posts: 780
    • View Profile
The workaround is to use two separate objects for lights:
1. The visible part, which will be visible directly, in reflections, in refractions - it does not emit light, but it is visible. Example: LightMtl with "emit light" off; rayswitch
2. The invisible part, which casts light into the scene - e.g. a Corona Light set to fully invisible

The issue here is that the "prevent black" option only works for direct visibility (not for reflections and refractions). We know about it and want to provide a fix as soon as possible.
Thank you i will follow in that way.