Author Topic: Occlude other Lights  (Read 4663 times)

2018-05-07, 15:54:15

martinfdc

  • Active Users
  • **
  • Posts: 66
    • View Profile
In a Light Material there is the option to Occlude Other Lights.

What does this option do?

2018-05-07, 16:10:32
Reply #1

YURII

  • Active Users
  • **
  • Posts: 61
    • View Profile
    • YURII SUHOV
If you un-thick it it will not cast shadows from other lights.

2019-08-27, 17:13:10
Reply #2

3dkobi

  • Active Users
  • **
  • Posts: 116
    • View Profile
Bumping this thread - why would I want a certain light to cast shadow from a different light ? Shouldn't this option be ticked "off" as default ? Or am I missing something ?

Peace,
Kobi

2019-08-27, 17:26:48
Reply #3

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3457
    • View Profile
Because a light source has to be some sort of physical object in reality, and as such would in reality act as something that blocks other lights.

2019-08-27, 17:33:31
Reply #4

3dkobi

  • Active Users
  • **
  • Posts: 116
    • View Profile
sounds logic :)

2020-10-10, 02:32:52
Reply #5

itsmillertime65

  • Users
  • *
  • Posts: 2
    • View Profile
This Occlude option does not seem to work in Cinema 4D with Corona Build timestamp: Aug 25 2020 09:45:14 Version: 6.0. I have 2 planes with different Corona Light Materials stacked in front of eachother with occlude unchecked on the light that's behind the other. When it's unchecked I get no light in my scene at all. Anyone have a workaround for this?

2020-10-10, 04:06:58
Reply #6

Cinemike

  • Active Users
  • **
  • Posts: 671
    • View Profile
Two questions:
1) Did you make sure the normals of your planes are pointing towards the object(s) you want to illuminate?
2) Did you make sure the plane closer to the object(s) you want to illuminate is the one with the light material where "Occlude other lights" is unchecked (you would not want the closer light object to "cast shadow" in this case)?

2020-10-10, 18:48:42
Reply #7

itsmillertime65

  • Users
  • *
  • Posts: 2
    • View Profile
Two questions:
1) Did you make sure the normals of your planes are pointing towards the object(s) you want to illuminate?
2) Did you make sure the plane closer to the object(s) you want to illuminate is the one with the light material where "Occlude other lights" is unchecked (you would not want the closer light object to "cast shadow" in this case)?

Hi Mike,
Thanks for the reply and info! I did ensure both of these things. The lights in my scene are Corona Light Materials and it seems there is a bug with these materials and occlude not working. I replaced my light materials with normal Corona lights and occlude works with them. I submitted a bug report and was told this option works best with normal lights but it's obviously supposed to work with light materials too or else why would the option be there?

2020-10-11, 01:43:32
Reply #8

burnin

  • Active Users
  • **
  • Posts: 1041
    • View Profile
Light Object's and Material's occlusion are working same here. R23 w/ Corona 6.1
Can you share an example?
« Last Edit: 2020-10-11, 01:48:46 by burnin »