Author Topic: [solved] Opacity map doesn't ignore reflection on mesh backside.  (Read 1146 times)

2017-12-19, 09:12:26

Jens

  • Active Users
  • **
  • Posts: 130
    • View Profile
    • Ikonoform
Hi

I'm experiencing the attached result when rendering on 1.7 RC2. Scene was done in this version, so I don't know if it has always behaved like this. It doesn't matter if I have DR enabled or not.

It seems like the opacity map doesn't ignore the reflections cast on the mesh backside.

Here I have some simple shop awnings behind street trees. If the material on the awning is reflective, it will bounce the light on the backside of the tree leaves mesh and produce the attached result.

I'm just removing the reflection on the awning material as a quick fix for the project, but I don't think it should behave like this right?

« Last Edit: 2017-12-19, 13:20:48 by maru »
My small 3D model shop: www.ikonoform.com/shop
My arch viz blog: www.ikonoform.com/blog

2017-12-19, 09:39:26
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10304
  • Marcin
    • View Profile
I am not quite sure what is happening here, but it definitely looks incorrect. Could you send us a scene (preferably simplified)?
Are you not by any chance using refraction for your tree leaves?

2017-12-19, 10:19:44
Reply #2

Jens

  • Active Users
  • **
  • Posts: 130
    • View Profile
    • Ikonoform
Uploaded scene with just the tree, awnings and a bright environment color. (It still happens in this scene when awning/canopy material has a reflection value).

Yes, leaves have a translucency map and a value of 0.6. If I set this to 0, there is no change at all. Only thing that helps seems to be removing refl. value on awning material.
My small 3D model shop: www.ikonoform.com/shop
My arch viz blog: www.ikonoform.com/blog

2017-12-19, 13:19:59
Reply #3

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10304
  • Marcin
    • View Profile
Checked the scene.

Like I said - you are using refraction for the leaves. Please never ever do it. Use translucency, opacity, but not refraction.

2017-12-19, 17:31:48
Reply #4

Jens

  • Active Users
  • **
  • Posts: 130
    • View Profile
    • Ikonoform
sorry about that Maru, deadline later today and thought I'd better report before moving on to a new project. I can confirm there is no problems if I set refrac value to 0 or tick the "thin" option. But I agree. There shouldn't be any refraction at all. Was a vray mat an 1 click convert, only added the correct translucency map manually as it seems to get rid of them when converting.
My small 3D model shop: www.ikonoform.com/shop
My arch viz blog: www.ikonoform.com/blog