Corona Renderer Forum

Corona Renderer for 3ds Max => [Max] Feature Requests => Topic started by: lupaz on 2020-10-13, 16:47:00

Title: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-13, 16:47:00
Hi there.

I'm working with a scene that has a huge amount of Forest pack elements (trees) and mountains with 2.5D displacement. So it's a heavy one.
I need to wait a long time to have response on the right-click on the viewport when using it for IR in order to stop it, making the whole workflow painfully slow.
It would be great if you could make it more responsive during the processing of whatever is making 3Ds max to not respond.

Thanks!
Title: Re: Stop IR in viewport ASAP
Post by: 3dboomerang on 2020-10-14, 08:09:17
that would be Forest Pack Pro making your scene impossible. Espeacially in IR.

Forest Packs reloading when selecting a different camera
Using point cloud display is junk, use proxy-plant display for trees
Have all Forest Pack Pro geometry turned to Proxies (make sure to avoid adding crp_ as prefix or ur Forest Packs will get broken)
Dont use "edge mode" unless it's really necessary, it make (re-)computing the scene for rendering ALOT heavier

The non-responsiveness can prob be part of your viewport being to heavy from those Forest Packs, when doing a render in IR with Forest Packs enabled, you will see the Forest Packs vanish from the viewport. You can make them appear by selecting them from an explorer window (layer explorer, etc...) whilst doing IR.

Again: I'm looking at Forest Pack Pro for this... Not Corona.

Grts
Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-14, 16:50:23
that would be Forest Pack Pro making your scene impossible. Espeacially in IR.

Forest Packs reloading when selecting a different camera
Using point cloud display is junk, use proxy-plant display for trees
Have all Forest Pack Pro geometry turned to Proxies (make sure to avoid adding crp_ as prefix or ur Forest Packs will get broken)
Dont use "edge mode" unless it's really necessary, it make (re-)computing the scene for rendering ALOT heavier

The non-responsiveness can prob be part of your viewport being to heavy from those Forest Packs, when doing a render in IR with Forest Packs enabled, you will see the Forest Packs vanish from the viewport. You can make them appear by selecting them from an explorer window (layer explorer, etc...) whilst doing IR.

Again: I'm looking at Forest Pack Pro for this... Not Corona.

Grts

Thanks.
Just to clarify: I don't have Forest Pack elements visible on the viewport, or very few. I'm not having viewport issues.
I'm not using edge mode.
The geometry that I have in the Forest object are Corona Proxies.
I don't have the issue of Forest Pack objects vanishing.

Title: Re: Stop IR in viewport ASAP
Post by: maru on 2020-10-14, 16:55:25
Can you try lowering the number of CPU threads for IR in Render Setup > System > System Settings? It sounds like the CPU is too busy to quickly react to the right-click.
Is this happening only with the Corona UI, or the whole 3ds Max UI?
Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-14, 23:31:54
I made a short video:

https://youtu.be/WlDXVOYr3FQ (https://youtu.be/WlDXVOYr3FQ)

I clicked on the corona IR window as soon as the video starts, in second 2 or 3, and I keep right clicking on it several times. The 3ds max UI doesn't respond either. You'll see the menu opening much later.
Edit: I tried lowering the CPU threads but the result is the same.
Thanks.
Title: Re: Stop IR in viewport ASAP
Post by: Frood on 2020-10-15, 09:52:58
I don't have Forest Pack elements visible on the viewport, or very few.

Unfortunately it still slows down everything. Even if you "freeze" all objects, hide them, whatever. It's a pain. (The vanishing objects were fixed in one of the latest FPP versions, making it even more sluggish). Quick test: Have a somewhat heavy scene with FP objects, create a box, Alt-Q that box and start IR. You wait for ages until IR starts to render ... a box. I get even missing assets warnings about FPP objects from Corona when starting IR with a single box without material. FPP gets the prerender notification, does not create any items as it should (you can see this in the max log if FPP is set to "debug") but Corona seem to process them (or the assets?) anyway. It's absolutely annoying.


Good Luck



Title: Re: Stop IR in viewport ASAP
Post by: denisgo22 on 2020-10-15, 12:25:52
may be you have Corona proxy objects visibility in mesh mode in scene??/ one proxy object in mesh mode will be enough for slow down viewport performance
Title: Re: Stop IR in viewport ASAP
Post by: Frood on 2020-10-15, 17:31:58
Ok, the original post was about stopping IR, then I dared to derail a bit because lupaz showed a video where IR was started. Now it's about IR performance generally again it seems :) Anyway, I see no difference using mesh mode or box proxy here. Which kind of setup are you referring to? You mean CoronaProxy scattered with FPP and CoronaProxy set to Viewport Display "Full mesh" and FPP Display options "Mesh"?

@lupaz: Another feature which causes issues with all kinds of plugins and setups using IR is the viewport statistics (hotkey 7). I would disable it generally by default, in your video it's active.


Good Luck



Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-15, 18:06:18
Ok, the original post was about stopping IR, then I dared to derail a bit because lupaz showed a video where IR was started. Now it's about IR performance generally again it seems :) Anyway, I see no difference using mesh mode or box proxy here. Which kind of setup are you referring to? You mean CoronaProxy scattered with FPP and CoronaProxy set to Viewport Display "Full mesh" and FPP Display options "Mesh"?

@lupaz: Another feature which causes issues with all kinds of plugins and setups using IR is the viewport statistics (hotkey 7). I would disable it generally by default, in your video it's active.


Good Luck

Thanks Frood. I didn't know that about the statistics. Too bad. I really need that.


Unfortunately it still slows down everything. Even if you "freeze" all objects, hide them, whatever. It's a pain. (The vanishing objects were fixed in one of the latest FPP versions, making it even more sluggish). Quick test: Have a somewhat heavy scene with FP objects, create a box, Alt-Q that box and start IR. You wait for ages until IR starts to render ... a box. I get even missing assets warnings about FPP objects from Corona when starting IR with a single box without material. FPP gets the prerender notification, does not create any items as it should (you can see this in the max log if FPP is set to "debug") but Corona seem to process them (or the assets?) anyway. It's absolutely annoying.


Good Luck

Regarding turning forest pack objects off, in my case the performance changes drastically, going back to normal.
But, if the Corona team can do something about the CPU power it gives to forest at render time, it would be great. Even if Itoo does something about it, I can't update their plugin anymore (expired service)
Title: Re: Stop IR in viewport ASAP
Post by: Frood on 2020-10-15, 19:04:04
Too bad. I really need that.

You just have to try from scene to scene if it does any damage, it does not necessarily so. At the other hand: when using a scatterer, it shows unfeasible data anyway.

Regarding turning forest pack objects off, in my case the performance changes drastically, going back to normal.

What exactly do you mean by "turning off"? Hiding? Freezing? Going to FP -> Display -> "Freeze all Forest objects"?


Good Luck



Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-15, 19:13:40

What exactly do you mean by "turning off"? Hiding? Freezing? Going to FP -> Display -> "Freeze all Forest objects"?


Yes. Sorry. I meant hiding them (from the scene explorer).
Title: Re: Stop IR in viewport ASAP
Post by: romullus on 2020-10-15, 19:16:00
Another feature which causes issues with all kinds of plugins and setups using IR is the viewport statistics (hotkey 7).

I never heard about that. Is it for real? I use statistics all the time, am i hindering performance of my scenes?
Title: Re: Stop IR in viewport ASAP
Post by: Frood on 2020-10-15, 20:16:51
Yes. Sorry. I meant hiding them (from the scene explorer).

Ah, ok. So what do you get if you do the above in your scene: create a box, ALT-Q it and start IR? How fast does it work for you?

I never heard about that. Is it for real?

I encountered this with 2 plugins, one of them was (and is) Laubwerk (https://www.laubwerk.com/), the other I don't remember, sorry.


Good Luck



Title: Re: Stop IR in viewport ASAP
Post by: romullus on 2020-10-15, 20:30:31
Maybe this more due to the plugins, than the statistics? I use very few plugins, so i think i should be safe :] Anyway, thanks for the info!
Title: Re: Stop IR in viewport ASAP
Post by: Frood on 2020-10-15, 20:48:38
Maybe this more due to the plugins, than the statistics?

Well... both. If e.g. using Laubwerk AND having statistics activated: 1fps. If switching statistics off: normal performance.

I use very few plugins, so i think i should be safe :]

Yes, as mentioned it's just one thing to check. And If I have no knowledge about the scene I recommend to switch it off - just to be sure. But don't worry about it on a day like this ;]


Good Luck





Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-16, 16:28:08
So what do you get if you do the above in your scene: create a box, ALT-Q it and start IR? How fast does it work for you?



If I create a box in the same scene I was talking about originally, and isolate it (ALT-Q), Corona renders it immediately.
Title: Re: Stop IR in viewport ASAP
Post by: Frood on 2020-10-16, 16:42:57
Holy teapot. This is interesting. Do you have a camera referenced in the FPP objects or set to "Auto assign"? I mean in Forest Object -> Camera

?


Good Luck



Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-16, 17:51:01
Holy teapot. This is interesting. Do you have a camera referenced in the FPP objects or set to "Auto assign"? I mean in Forest Object -> Camera

?


Good Luck

They're all in "auto assign to active view" mode.
Title: Re: Stop IR in viewport ASAP
Post by: arqrenderz on 2020-10-17, 17:11:50
Forest is launching the 7 version "soon" I really hope that it comes with some magic on the performance side of things, right now is painfully slow to work on big scenes with tons of scattered forest objects.
Title: Re: Stop IR in viewport ASAP
Post by: maru on 2020-10-19, 17:01:10
@lupaz and others with Corona IR+Forest Pack performance issues - can you please send us simple scenes where the issue could be reproduced?
Reminder: it's best to archive the scene with all assets and upload it here - https://corona-renderer.com/upload
Then please let me know here which upload method you chose and what the file name was.
We will also need the exact Corona and FP versions, and how to reproduce the problem.

Thanks!
Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-19, 23:38:42
Sending attached to this message a ZIP file with a very simple scene.
The issue is reproduced in it.
Just click on "start interactive session". It takes a long time before you can stop it or do anything else.

I'm using:
Corona version: 6 (Hotfix 1)
Full-speed, Non-debug, MaxSDK 2020
Build timestamp: Sep 25 2020 15:41:07


Forest Pro 6.2.2

3ds Max 2020.3

Windows 10

Thanks Maru.
Title: Re: Stop IR in viewport ASAP
Post by: Frood on 2020-10-20, 09:25:06
Forest Pro 6.2.2
3ds Max 2020.3
Windows 10

And using the above + Corona version: 7 (DailyBuild Sep 16 2020) the (unchanged) scene even crashes after starting/stopping two or three times (exception in LegionLib_Release). This is this kind of issue we have permanently here - and since years. Same with Camera movement: Put FPP into debug mode and watch/monitor max.log when moving the cam: It permanently creates its 458192 items at every single move and slows down everything because the camera is referenced into the Forest object and FP updates the distribution. If you A) change from CoronaCamera to perspective or B) remove it from the Camera section of FP, it does what it should for IR: objects are created only once and you can move around normally. Stopping IR works immediately in all cases though.


Good Luck



Title: Re: Stop IR in viewport ASAP
Post by: lupaz on 2020-10-21, 23:13:32
The same happens with hair and fur
Title: Re: Stop IR in viewport ASAP
Post by: maru on 2020-10-26, 14:02:52
Thanks Lupaz. I was able to reproduce it using your scene. It also doesn't happen with V-Ray, which is interesting.

(Internal ID=584187302)
Title: Re: Stop IR in viewport ASAP
Post by: maru on 2020-10-26, 14:17:45

And using the above + Corona version: 7 (DailyBuild Sep 16 2020) the (unchanged) scene even crashes after starting/stopping two or three times (exception in LegionLib_Release). This is this kind of issue we have permanently here - and since years. Same with Camera movement: Put FPP into debug mode and watch/monitor max.log when moving the cam: It permanently creates its 458192 items at every single move and slows down everything because the camera is referenced into the Forest object and FP updates the distribution. If you A) change from CoronaCamera to perspective or B) remove it from the Camera section of FP, it does what it should for IR: objects are created only once and you can move around normally. Stopping IR works immediately in all cases though.

Good Luck

I did not get a crash when starting and stopping IR 5 times in the scene Lupaz provided with the Corona 7 daily. It always starts rendering eventually, after a long freeze.
No crashes when moving the camera either, but it froze for a much longer time.

There have always been issues with Forest's "limit to camera visibility" option and Corona, especially with IR.