Author Topic: Problem with Material using Displacement  (Read 587 times)

2020-10-08, 12:04:12

KAB

  • Active Users
  • **
  • Posts: 6
    • View Profile
Hello

I have the problem when rendering with materials that use displacement (carpet, gravel) that the material draws the polygon geometry. I send you a test scene with a test image so you can see what I mean.

Do you know a solution?
Thanks a lot,
KAB

2020-10-08, 13:14:13
Reply #1

burnin

  • Active Users
  • **
  • Posts: 1041
    • View Profile
Go to
Render settings >Corona >Performance settings tab
and disable/uncheck New 2.5D displacement


2020-10-08, 14:21:30
Reply #2

KAB

  • Active Users
  • **
  • Posts: 6
    • View Profile
Great! Many thanks it seems to work out this was!

2020-10-28, 18:25:19
Reply #3

KAB

  • Active Users
  • **
  • Posts: 6
    • View Profile
Hi

I work now on a new Project and strangely I have the same problem with the visible polygone lines by using the displacement material option even after unchecking NEW 2.5D Displacement.

Does anyone know another solution for this problem?


« Last Edit: 2020-10-28, 18:39:38 by KAB »

2020-10-30, 22:53:19
Reply #4

burnin

  • Active Users
  • **
  • Posts: 1041
    • View Profile
Yes... and another thing to note first.

Basically, what you're experiencing is a standard path tracer shading issue over a long polygon. Gets more pronounced with tris.
More about...

So here i'd advise to simply untriangulate geo & add edge weighted loops on the sides.
Also, to simplify it further, since it's a micro - visual element, use only bump in material instead of displacement.