Author Topic: Propagating Mask not working  (Read 771 times)

2020-08-06, 16:52:39

Ben

  • Active Users
  • **
  • Posts: 11
    • View Profile
Hi there,

for some reason I cannot disable transparent objects / glass materials for masks. I tried all the options under "propagate mask" for the glass material but it doesn't change anything. The older "visible in masks" checkbox is gone, so I assumed this should be the correct place to adjust the setting, no?

Thank you in advance.

Ben
Cinema 4D Studio R17
Corona Renderer 6 rc 2

2020-08-06, 17:19:01
Reply #1

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3343
    • View Profile
The "Always without scattering" - two things though, that might get renamed; and a developer was having a look at it earlier today and found it may not be working as expected in RC 2 (though it did earlier), so it may need to wait for another RC for the fix. Earlier, when I was making images for the release blog/video, it was working (in that, it makes any object completely invisible in the mask, as if it was not there in the scene at all - let me know if that was not the result you were looking to achieve though!)

2020-08-06, 17:46:26
Reply #2

Ben

  • Active Users
  • **
  • Posts: 11
    • View Profile
Thanks for the quick reply, sadly that option isn't working for me, neither "always" nor "always without scattering". There is simply no change in the masks between any of the possible selections.

I am still running on RC1 so maybe RC2 will resolv this, I ll give it a try.
Cinema 4D Studio R17
Corona Renderer 6 rc 2