Corona Renderer Forum

Corona Renderer for Cinema 4D => [C4D] Bug Reporting => Topic started by: robpayne on 2020-10-02, 12:49:53

Title: Team render doesn’t save
Post by: robpayne on 2020-10-02, 12:49:53
Team Render doesn’t ever save my images, meaning I have to be there at the end to save them myself. It works fine with other renderers, so why not Corona? I often have many long renders to process overnight, but I can’t use the render queue or takes system to render them because they won’t save. It’s a problem.

Is anybody else having the same problem? Is there a way to fix it?
Title: Re: Team render doesn’t save
Post by: TomG on 2020-10-02, 13:48:54
Which Corona version, which C4D version, which OS, and what method are you using for TR, the web server version or the "TR to PV" version?

For me, I use the web server version of TR quite a lot, and it saves as expected.
Title: Re: Team render doesn’t save
Post by: mmarcotic on 2020-10-02, 16:18:56
I have just tried Team Rendering between two machines and got a saved result as well. Is it possible to pass the scene(s) which are problematic over to us?

Thanks,
Jan
Title: Re: Team render doesn’t save
Post by: robpayne on 2020-10-02, 16:23:52
Hi TomG,

Thanks for getting back to me. I’ve assumed this broken for so long that I’d stopped looking for a solution, but some closer inspection shows that the problem only occurs when using either:

– A relative save path (i.e. “./folder name/…”)
– Naming tokens for folders (e.g. $prj)

This is the case whether rendering TR to PV or with the Server. I usually use both for all of my projects (“./output/$prj/$prj”), hence why renders haven’t been saving all this time. So here are a few examples:

Fails
./output/$prj/$prj
/Users/User/$prj/test

Works
/Users/User/test/test
/Users/User/test/$prj

It’s really hazardous that renders might not save at all, particularly with the TR Server where it’s not possible to save manually. I’m attaching a screen grab showing the Server after two projects rendered with 0 results. Obviously there isn’t always the time to re-render, which is why I think this needs to be fixed or at least alerted so used don’t fall into the same trap.

I’ve experienced this problem with all of the daily builds right back to 2019-09-20 (Corona 5, I think), in Cinema 4D R23, 22 and 21, in Mojave and now Catalina (10.15.6).

Rob
Title: Re: Team render doesn’t save
Post by: robpayne on 2020-10-02, 16:25:16
Hi Jan,

See my reply above. Here are two files that fail to save using Team Render.

Best,
Rob
Title: Re: Team render doesn’t save
Post by: TomG on 2020-10-06, 18:39:42
We were able to reproduce here (just tested the token example, but that was enough), so we have it tracked now at (Internal ID=574105417)
Title: Re: Team render doesn’t save
Post by: robpayne on 2020-10-06, 18:41:35
Excellent, thank you