Author Topic: V7 support in macOS 10.13.  (Read 723 times)

2021-02-27, 15:58:38

jojorender

  • Active Users
  • **
  • Posts: 96
    • View Profile
Is there any way V7 dailies and/or the upcoming release can be supported in macOs 1013.?
When you started V7 dailies last year it said, quote: “From now on, Corona will require macOS version 10.13 or newer”.
Well, it “successfully” installs in 10.13, but corona in c4d missing and opening CIE gives me “You can’t use this version of the application “Corona Image Editor.app” with this version of macOS.”
V7 12/31 is the last daily that worked.
MacOs 10.13.6
C4D Studio R18.057

2021-03-01, 10:11:32
Reply #1

mmarcotic

  • Corona Team
  • Active Users
  • ****
  • Posts: 283
  • Jan - C4D QA
    • View Profile
Hello,

unfortunately, it has been decided that we would only support the previous 3 versions (for now that means 10.14, 10.15, 11).
If you want to continue using 10.13, I would recommend either using the 31-12-2020 daily build (as you have) or the V6 hotfix 1 stable release.

Thank you for understanding,
Jan
Learn how to report bugs for Corona in C4D here.

2021-04-12, 17:32:52
Reply #2

mitchino

  • Active Users
  • **
  • Posts: 85
    • View Profile
This is very disappointing. I run 10.13.6 because that's the last version with nvidia drivers for running Octane and Redshift. I use those two and Corona depending on the job in hand. Looks like Corona won't get used so much. Ok I can use V6, but I want to use the new material workflow.

2021-04-23, 22:16:20
Reply #3

jojorender

  • Active Users
  • **
  • Posts: 96
    • View Profile
I'm actually surprised that not more mac users ask for 10.13 support because they need nvidia cards and switching to 10.14 and newer is not an option.

I understand it's probably just easiest to tie corona to Apple's OS support cycle, but if at all possible, maybe a "experimental 10.13 version" without any tech support etc... a "use at your own risk" version, no dailies, just V7 when released...
Already sounds unrealistic as I'm typing this, but a man can dream... dammit!



MacOs 10.13.6
C4D Studio R18.057

2021-04-23, 23:42:53
Reply #4

johnnyswedish

  • Active Users
  • **
  • Posts: 128
    • View Profile
Hi jojorender,

I have been a loyal Mac user since the Quadra working as a graphic designer. I eventually morphed into 3d using my first Commodore Amiga with Sculpt 3D, then moved onto Strata 3D on Mac, then C4D... I recently made the scary switch to PC last year and wish I had done this 15 years ago! I was SO blown away by the stability and expansion options (not to mention PURE power of CPU) compared to Macs. If you are serious about 3D, switch to PC. It truly is the brighter side of life :-) John

2021-04-24, 17:28:19
Reply #5

jojorender

  • Active Users
  • **
  • Posts: 96
    • View Profile
I recently made the scary switch to PC last year and wish I had done this 15 years ago!
Hi John
thanks for your input, and I get your point, but I promise you if you had made that switch 15 years ago, you would have not lasted a week on PC’s. I made the switch to Mac in 2006 and was blown away that a computer can actually run without crashing every couple of days.
When the MacPro died in a trashcan I started hackintosh-ing and besides that silly Apple - Nvidia war, this worked out really well for me, Mac stability and PC’s raw CPU power.
Glad to hear the switch worked out for you and I might consider it if I feel it could really benefit my work, but we might all be on apple silicon once it can handle the workload...

Don’t forget, YOU are the brighter side of life, your PC is just a tool ;-)
Frank
MacOs 10.13.6
C4D Studio R18.057

2021-04-27, 16:53:48
Reply #6

johnnyswedish

  • Active Users
  • **
  • Posts: 128
    • View Profile
Hi Frank,

Totally get you and wise words :-) Hope you get resloved. John

2021-04-29, 11:28:21
Reply #7

andeltoz

  • Active Users
  • **
  • Posts: 9
    • View Profile
Hello. I am also an OSX 10.13 user and I am very angry that support for this operating system has been dropped with the new versions of Corona. But on the other hand, since everything passed into the hands of the Chaos Group, this was the choice. I had both subscriptions but I had to request a refund of the amount paid for Vray 5 because this also does not work on OSX 10.13. Among other things, before making the purchase of the new subscription to Vray 5, the incompatibility was not even reported on the official website of Chaos. When I asked a specific question, I was told that it was an oversight.

2021-04-29, 13:43:51
Reply #8

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1940
  • Bengamin
    • View Profile
    • Cormats
Hi, I'm not a macOS user but I was wondering how long one hangs onto using an old OS version? Are there any major factors that prevent you from upgrading your OS? Curious...

2021-04-30, 09:21:53
Reply #9

andeltoz

  • Active Users
  • **
  • Posts: 9
    • View Profile
In my case, having an iMac mid 2011, the last possible upgrade was to OSX High Sierra. The iMac is an i7, 32 Gb of ram, 1 Tera hd SSD. So a machine still able to work and with decent results in terms of speed, considering that I have slaves with which to distribute the calculation.

2021-04-30, 19:37:55
Reply #10

jojorender

  • Active Users
  • **
  • Posts: 96
    • View Profile
Hi Beanz,
the main reason to stick with macOS 10.13 is that Nvidia stopped offering gpu drivers for Mac 10.14 and newer. If you need CUDA for whatever reason, Nvidia is your only choice.
Even when considering using a different machine for C4D/ corona, buying a 3 year old AMD gpu for around $900 ($250 originally) in this current crypto craze is just ridiculous. 
Up until M1 Macs, recent yearly os updates where largely cosmetic (“fun” new emoticons, etc.) and designed to sell more products.

The reality for me, if I want to run corona V7, I would need to buy new hardware and also upgrade c4d.
I’m still on R18 and don’t really have a reason to upgrade. It runs very stable and offers all the features that I need.
So, it’s very expensive to switch to corona V7 because of dropped 10.13. support.

Sorry for rambling, have a great weekend.
MacOs 10.13.6
C4D Studio R18.057