Author Topic: Corona Light Material - Emission can't be turned off  (Read 6119 times)

2016-04-22, 08:36:46

sht

  • Active Users
  • **
  • Posts: 69
    • View Profile
If the Emit Light option is unchecked instead of turning emission off  light gets emitted on both sides.
See screenshots attached.

2016-04-26, 08:47:39
Reply #1

sht

  • Active Users
  • **
  • Posts: 69
    • View Profile
Anyone having the same problem?
Or does it work on your installation?

I reinstalled the newest release (A5.1) but still not workinig.

Thanks!

2016-04-26, 12:31:00
Reply #2

burnin

  • Active Users
  • **
  • Posts: 1427
    • View Profile
I found the bug is with "Occlude other lights".
Uncheck it and it should behave properly. At least it does so here.

2016-04-26, 12:35:55
Reply #3

sht

  • Active Users
  • **
  • Posts: 69
    • View Profile
Thanks for the tip.

But if I deactivate occlude other lights it disappears completely.

2016-04-26, 13:45:36
Reply #4

burnin

  • Active Users
  • **
  • Posts: 1427
    • View Profile
Material Editor > Properties > Visible Directly (check)

2016-04-26, 17:23:57
Reply #5

sht

  • Active Users
  • **
  • Posts: 69
    • View Profile
Direct Visibility is checked.

But already in the preview the material is not visible.
If I render everthing is black

I attached two screenshots and the scene.

2016-04-26, 22:34:13
Reply #6

burnin

  • Active Users
  • **
  • Posts: 1427
    • View Profile
humm... it would help if you'd check Emit light on the material Emission channel and set renderer to Corona... ayayay.

2016-04-27, 08:40:09
Reply #7

sht

  • Active Users
  • **
  • Posts: 69
    • View Profile
Hi,

I forgot to save before I uploaded the file. Of course the renderer is set to corona ;-)

Actually it is the emit light option that I want to turn off which is not working as supposed ;-)
I testet it in the 3dsMax Version there it behaves correctly. So I assume it is a bug in the C4D version.

Anyway thanks for your effort!


2017-03-28, 17:12:35
Reply #8

houska

  • Former Corona Team Member
  • Active Users
  • **
  • Posts: 1512
  • Cestmir Houska
    • View Profile
Hi! Although this is old, I can reproduce it exactly as you described! This is indeed a bug!