Author Topic: lights showing as black through refractive glass  (Read 2442 times)

2019-08-02, 10:55:07

Rhodesy

  • Active Users
  • **
  • Posts: 508
    • View Profile
We are having some issues that should be obvious from the attached image. Basic corona rectangular lights used but they turn black when looking at them through the glass. We use refraction in the glass material (not set to thin) as we feel it looks much more realistic and the rendering hit isnt that bad when its so thin. But there is this issue with corona lights not showing through the glass. Light emitting materials dont have this problem.

We are using Corona 4 RC3, so should probably upgrade to the latest but hopefully there is something obvious we can do to fix this?

Thanks
Rob

2019-08-02, 12:42:59
Reply #1

Hilmar

  • Active Users
  • **
  • Posts: 14
    • View Profile
not sure if it was Vray…… in the glassmaterial you could define how many time the lightray should travel between the glass and which Color it should get after Xtimes.

2019-08-02, 12:49:33
Reply #2

Hilmar

  • Active Users
  • **
  • Posts: 14
    • View Profile
if you set this MAX RAY DEPTH to low, it will happen as well.

2019-08-02, 12:59:30
Reply #3

Rhodesy

  • Active Users
  • **
  • Posts: 508
    • View Profile
Thanks, although I dont think the max ray depth should make a difference here as it happens when only going through 2 faces.

2019-08-02, 13:18:24
Reply #4

Frood

  • Active Users
  • **
  • Posts: 1753
    • View Profile
    • Rakete GmbH
What about the most obvious: Visibility in refractions is activated in the lights I presume?


Good Luck



Never underestimate the power of a well placed level one spell.

2019-08-02, 13:32:08
Reply #5

Rhodesy

  • Active Users
  • **
  • Posts: 508
    • View Profile
OK, we have tracked it down and think its a bug. If we set the directionality to 0.4 everything works as it should but 0.5 and higher it goes black through the glass. I will put it in the bugs section now.

2019-08-02, 14:39:19
Reply #6

Jpjapers

  • Active Users
  • **
  • Posts: 1503
    • View Profile
OK, we have tracked it down and think its a bug. If we set the directionality to 0.4 everything works as it should but 0.5 and higher it goes black through the glass. I will put it in the bugs section now.

I think this has been picked up before as i had the same issue