Author Topic: Render selected + visible in masks issues  (Read 3954 times)

2017-11-20, 14:43:35

Neil Cross

  • Active Users
  • **
  • Posts: 32
    • View Profile
Hi all

When rendering using viewport selection, is there a way to disable refractions?

Thanks!

(description of the problem starts from https://forum.corona-renderer.com/index.php?topic=18332.msg115150#msg115150)
« Last Edit: 2017-11-23, 10:02:06 by maru »

2017-11-20, 16:30:31
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 11413
  • Marcin
    • View Profile
1) What do you mean by "rendering using viewport selection"? Do you mean the "render selected" feature?
2) What do you mean by "disable refractions"? Refraction of the selected object? Do you want to render it as black? Or to lower the refraction depth?

Can you explain why you would need this? An example would be the most helpful.
Marcin Miodek | chaos-corona.com
Chaos Corona Support Team Lead | contact us

2017-11-21, 05:24:01
Reply #2

GabrielS

  • Active Users
  • **
  • Posts: 11
    • View Profile
I think he want to talk about the rendering selected function.

When you use it on an object behind a glass, the render is black.

2017-11-22, 13:08:40
Reply #3

Neil Cross

  • Active Users
  • **
  • Posts: 32
    • View Profile
1) What do you mean by "rendering using viewport selection"? Do you mean the "render selected" feature?
2) What do you mean by "disable refractions"? Refraction of the selected object? Do you want to render it as black? Or to lower the refraction depth?

Can you explain why you would need this? An example would be the most helpful.

Hi maru

I'm referring to the render select feature in render settings.

Assume the image below. I have selected the dining set in my viewport to render, however all my materials with refraction also render.
I understand its a good thing to have as you might see the dining table reflecting in the glass in the background.

just interested to know if there's a way to only render what you select. I know its easy to just cut the dining set out but a scene with lots or refraction can turn haywire lol.
Iv tried include exclude list, same issue.


2017-11-22, 17:16:41
Reply #4

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 11413
  • Marcin
    • View Profile
Wow. We will look into this!
Marcin Miodek | chaos-corona.com
Chaos Corona Support Team Lead | contact us

2017-11-23, 09:52:25
Reply #5

Neil Cross

  • Active Users
  • **
  • Posts: 32
    • View Profile
Wow. We will look into this!

Sorry maru this was my mistake. I had visible in masks unchecked which I see is checked by default.



2017-11-23, 10:00:54
Reply #6

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 11413
  • Marcin
    • View Profile
This looks like a bug to me.
Reproduced.

1) When using render selected > viewport selection and an object using a material with "visible in masks" off is selected, this object will not be rendered
2) When using render selected > viewport selection and an object using a material with "visible in masks" off is occluding the selected object, it will render like an "overlay" over the selected object
« Last Edit: 2017-11-23, 10:07:35 by maru »
Marcin Miodek | chaos-corona.com
Chaos Corona Support Team Lead | contact us

2017-11-23, 10:35:34
Reply #7

Neil Cross

  • Active Users
  • **
  • Posts: 32
    • View Profile
Can you please save your scene to 2016

2017-11-23, 12:49:39
Reply #8

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 11413
  • Marcin
    • View Profile
Here you go, although it was rather a part of bugreport intended for the devs.
Marcin Miodek | chaos-corona.com
Chaos Corona Support Team Lead | contact us

2019-07-15, 11:12:03
Reply #9

Place

  • Active Users
  • **
  • Posts: 39
    • View Profile
Hi,
any news about this old bug?
I found a similar (if not the same) behaviour: in a scene with a background, I want to "render select" (or use an include/exclude list) only an object
but it cames up in the render another object, with a glass material, if it has the option "visible in mask" unchecked as in this case;
another way to not have the glass object to appear is to check the "Thin" option so indeed it's related to refraction too.
I attach a sample scene.
Thank you!
Man

2019-07-18, 11:18:32
Reply #10

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 11413
  • Marcin
    • View Profile
Thanks, looking into it, and I will be sure to refresh the original report too.
Marcin Miodek | chaos-corona.com
Chaos Corona Support Team Lead | contact us

2019-07-18, 11:37:06
Reply #11

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 11413
  • Marcin
    • View Profile
Confirmed. Reporting it to devs right now.
Solution / workaround: either enable "visible in masks" option for your glass material, or disable its refraction (enable thin glass mode).

(internal id=375795141)
« Last Edit: 2019-07-18, 11:43:12 by maru »
Marcin Miodek | chaos-corona.com
Chaos Corona Support Team Lead | contact us

2019-07-20, 16:02:12
Reply #12

Place

  • Active Users
  • **
  • Posts: 39
    • View Profile