Corona Renderer Forum

Corona Renderer for 3ds Max => [Max] I need help! => Topic started by: hetrisairi on 2021-06-17, 09:51:51

Title: Problem with render elements Masking ID and WireColor
Post by: hetrisairi on 2021-06-17, 09:51:51
Hallo, i need help with my problem. I can't understand why i have a bugs in render elements id and wire colors. Thanks for help.[img]
Title: Re: Problem with render elements Masking ID and WireColor
Post by: maru on 2021-06-17, 15:40:39
It's not a bug, it's a feature. ;)

What you see is the effect of mask propagation option.
Please see:
https://coronarenderer.freshdesk.com/support/solutions/articles/12000066916

If the objects that you see in the masks are not refractive or reflective, most likely this is the reason:
You will notice reflectivity in masks when propagation of masks is set to "Always" for a material that has no reflection or refraction. Preferably, the "Always" option should be used for materials that need both reflective and refractive propagation of masks.

To "fix" it, you can use the script which is attached at the very bottom of the page. It will disable the propagation option for all scene materials:
https://coronarenderer.freshdesk.com/helpdesk/attachments/12079418781

Title: Re: Problem with render elements Masking ID and WireColor
Post by: sprayer on 2021-06-17, 16:07:23
I think that script should be in corona converter =)
Title: Re: Problem with render elements Masking ID and WireColor
Post by: maru on 2021-06-18, 09:31:55
I think that script should be in corona converter =)

That is actually not a bad idea. :)

(Internal ID=494874855)