General Category > Corona Academy

Cannot access the videos

<< < (2/3) > >>

I was having the same/similar issues launching the videos and something that worked for me was to simply hold CTRL and then click the video thumbnail. This opened the player (on the same page) and then I could full screen it.
Might work for others too if you have this problem launching the videos.

3. What browser are you using and are you using some kind of adblocker plugin? Try disabling it on the Corona Academy website.

This is what solved it for me, my blocker was blocking vimeo cookies.

hey guys you do realise all your links dont work for the new videos ?

Just tried - everything works here.

Support helped me.
I don't know why, but (on a Mac) Command + Clicking on the video thumbnails made id work. on a Windows machine it should be Control + Click.
One fix was also: clicking on the video thumbnail an then get back to the page you came from and clicking again.

Maybe you can try that if you have problems.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version