Author Topic: Simple shadow problem with Corona 8  (Read 681 times)

2022-05-16, 11:30:30

andreu.taberner

  • Active Users
  • **
  • Posts: 18
  • more about my work here www.andreutaberner.com
    • View Profile
Hi!

Shadows doesn´t render correctly when a map is addded to the Refl.Glossiness.
The shadow improves as I reduce the amount of the refl. glosiness map. This improvement seems to be affected by the distance to the object casting the shadow.

See attached image.

Notes:
The shadow comes from a proxy tree in this example, but the problem occurs with regular objects as well.

Software:
-3ds Max 2022
-Corona 8


2022-05-16, 15:53:53
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 11415
  • Marcin
    • View Profile

2022-05-16, 16:25:02
Reply #2

andreu.taberner

  • Active Users
  • **
  • Posts: 18
  • more about my work here www.andreutaberner.com
    • View Profile
I did some quick tests.

My conclusion is that any changes on Object properties as Cast shadows or Visible to Refractions/Refractions will create wrong results on top of objects with a Glossiness different that 1,0 (regardless if it is a map or just a number). it will basically show shadows, more or less dense, while Cast Shadows is unchecked.

This is a significant problem in archviz, especially for those planning to create fake shadows or fake reflections inside the 3D scene, to later add objects, like trees, in Photoshop.

« Last Edit: 2022-05-17, 14:03:59 by andreu.taberner »

2022-05-22, 13:16:32
Reply #3

DelightingPictures

  • Primary Certified Instructor
  • Active Users
  • ***
  • Posts: 64
    • View Profile
    • Delighting Pictures
In the case of Corona Render 8, the same happens to us, but if you change the ground material to a Physical material, the shadows will appear correct. Try it and let us know if it improves. In our case, I think it happens without having objects hidden from the camera.

https://forum.corona-renderer.com/index.php?topic=36714.0