Author Topic: Multipass => Render only masks (disable shading) request.  (Read 5963 times)

2020-01-31, 09:32:06

JPeters

  • Active Users
  • **
  • Posts: 87
    • View Profile
Hi there,

Got a simple request really, when disabling shading in the multipass tab to render only masks, can we please stop writing RGB images with "Shading was disabled to render masks faster."? You can still render them in the viewport to show what is going on but there really is no need to actually write them out.

These RGB files overwrite the original RGB output from earlier renders which is very annoying and totally unnecessary. There is a reason why I *only* want to render masks and that reason is not to overwrite previous RGB output with garbage images.


For instance, I render an animation in separate .tif sequences per pass but then later find out my mask numbering is off. I then change my mask settings and disable shading in the multi-pass tab after which I render out the masks only again. But at this point corona also overwrites my RGB .tiff sequence with garbage images. Why?

Cheers,

Joep

2020-01-31, 09:51:10
Reply #1

houska

  • Former Corona Team Member
  • Active Users
  • **
  • Posts: 1512
  • Cestmir Houska
    • View Profile
Well, if I understand your request correctly, it makes total sense to me. Your files get overwritten, because you specified them to be overwritten in the "Save" section of the render settings. Whether you only render masks or whether you do normal shading doesn't have anything to do with it.

If I am reading this incorrectly, please correct me.

2020-01-31, 10:03:48
Reply #2

JPeters

  • Active Users
  • **
  • Posts: 87
    • View Profile
Why is there an option to only render masks if it doesn't only render masks then?

Or is there an option to disable writing just the RGB component somewhere so RGB won't be overwritten by a file containing no RGB render information (only text)?

Cheers,

2020-01-31, 10:35:29
Reply #3

houska

  • Former Corona Team Member
  • Active Users
  • **
  • Posts: 1512
  • Cestmir Houska
    • View Profile
It does render only masks. But then, when you want it to save into a tif, it does exactly that.

Just to make sure - you have output file specified in the "Save" section of the render settings, right?

2020-01-31, 11:22:40
Reply #4

JPeters

  • Active Users
  • **
  • Posts: 87
    • View Profile
Ok, let me put it easier perhaps.

1) I render a sequence as multi-pass .tif file format, each pass/mask/ID/RGB/etc. get's its own .tif sequence written out.
2) I then find out something is wrong with my masks so I make some changes in the multi-pass dialogue of corona and/or change materials.
3) I enable "masks only" render in the multi-pass corona window since I do not need new RGB, just the masks.
4) Corona proceeds to write out a garbage RGB over my existing RGB which is filled with text.

5) I get annoyed because I specifically asked Corona to render only my masks and *NOT* my RGB.
6) Why does Corona render write out the RGB pass even though "masks only" is selected in the multi-pass dialogue? What is the function of "masks only" if you are still going to write out things that aren't masks?

And yes, I've selected the output in the "save" section of the render settings, otherwise you can't write out a sequence at all right?

The label for the tick box even specifically says "Disable Shading" yet corona doesn't disable shading, it renders out an image filled with text (enabled, not disabled) *AND* writes this garbage image out as RGB (enabled, not disabled).

Does that make sense?
« Last Edit: 2020-01-31, 11:33:57 by JPeters »

2020-01-31, 12:50:53
Reply #5

houska

  • Former Corona Team Member
  • Active Users
  • **
  • Posts: 1512
  • Cestmir Houska
    • View Profile
Thanks for the explanation! It all makes sense now.

I didn't realize that when saving to .tif, each pass has its own .tif file. And Beauty pass cannot be turned off, so it always gets overwritten even though you don't render it, because the "Masks only" option is turned on...

Yeah, that makes sense to me. We'll see what can be done. Thanks for the patience! ;-)

2020-02-03, 14:48:27
Reply #6

JPeters

  • Active Users
  • **
  • Posts: 87
    • View Profile
Hi Houska,

Thanks a lot, glad I could explain myself a bit better :)

Looking forward to seeing a potential solution!

2023-08-24, 10:13:49
Reply #7

Macler

  • Users
  • *
  • Posts: 2
    • View Profile
Any progress on this? I'm running into this issue aswell.


ML

2023-09-08, 08:33:30
Reply #8

HFPatzi

  • Active Users
  • **
  • Posts: 138
    • View Profile
I'll give that a +1111 ;)

Only solution right now would be either to change the save location and then manually move/replace the mask/pass sequence or to change the filename so that the rgb/beauty pass doesn't get overwritten and then manually delete the "fake" beauty pass. But then the new sequence still has a different filename, wich means you have to re-import/replace it manually in you editing software of choice ;)

2023-10-04, 08:01:58
Reply #9

bnji

  • Corona Team
  • Active Users
  • ****
  • Posts: 190
  • Benjamin
    • View Profile
    • Corona Renderer
Hi there,
Thanks for bringing this to our attention. I'll investigate further and provide additional info about this to the dev team.
In the meantime, another workaround would be to disable the checkboxes of the multi-passes that you don't want the files to be saved.
This way, you can render out the masks, and only those multi-passes will be saved.
We're sorry for any inconvenience.
Benjamin Rosas | chaos-corona.com
3D Support Specialist - Corona | contact us
Corona Uploader l Upload