Author Topic: Shadow Catcher for compositing.  (Read 2817 times)

2017-11-06, 07:04:57

lolec

  • Active Users
  • **
  • Posts: 172
    • View Profile
Hello, I'm trying to find the best workflow for corona shadow catcher and compositing. I followed a couple of tutorials, but still can't get the result I'm looking for.

My setup is a giant ground plane, giant wall in the horizon, shadowcatcher material assigned to both, video backplate and corona sun + sky.

Attached is an image with my results for you to see, here is my problem:

If I render in Always solid mode, I get the best result (see shadows over buildings #1 , see reflections on the ground #2) However, the render is slow and I loose the flexibility to color correct in after effects independently from the background.

If I render in For compositing mode, I get all the flexibility, but when I add the alpha, shadows don't look as nice #1, and I loose reflections completely, #2 and #3)  In my mind, For compositing + alpha should look almost identical to the Always Solid render, right?

The third option is  Always solid + alpha, Shadows are a little better, maybe the best, but I loose reflections on the ground completely #3, also, render times are not optimal, because Always Solid pass is slow and I have to render alpha separately.

How can I more closely approach Always Solid result in for compositing mode?  I notice alpha does not include reflections, maybe I need to check something? Should I include more passes ? which ones ?

Thanks a lot



2017-11-06, 10:25:30
Reply #1

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7296
  • Let's move this topic, shall we?
    • View Profile
    • My Models
First of all, i think that you're confusing something by saying that it's always solid mode that is slow. Actually it's the other way round - for compositing mode is slower... much much slower than other two modes. It's a bug, which hopefully will be adressed in the next release.

Anyway, i don't know why you need alpha with for compositing, if you'd multiply it with your backplate in post, you should get exactly the same look as with always solid in frame buffer.

By the way, why you're adding "giant wall with shadow catcher material" in your scene? What's its purpose?
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2017-11-06, 10:56:26
Reply #2

Christa Noel

  • Active Users
  • **
  • Posts: 910
  • God bless us everyone
    • View Profile
    • dionch.studio
ah finally someone mention the shadowcatcher compositing mode again :D
By the way, why you're adding "giant wall with shadow catcher material" in your scene? What's its purpose?
a question first, where is the "giant wall" you meant? or did you mean the plane which replicate the building?

2017-11-06, 15:36:50
Reply #3

lolec

  • Active Users
  • **
  • Posts: 172
    • View Profile
Well, I'm definitely missing something, here is the result of For compositing + Multiply I also tried all blending modes, none looked like Always solid.

The giant wall was just a workaround to get the always solid render to show the whole backplate since the visibility override was showing the video upside down/ split.

As I understand the correct setup should be:

Shadow catcher material with "for compositing" on big plane, corona sun and sky or HDR.

Should I render additional passes?


2017-11-06, 15:57:37
Reply #4

sprayer

  • Active Users
  • **
  • Posts: 794
    • View Profile
if you want just to reduce bounce light from objects to shadow catcher, you can use rayswitch material for shadowcatcher

2017-11-06, 17:13:06
Reply #5

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7296
  • Let's move this topic, shall we?
    • View Profile
    • My Models
Well, I'm definitely missing something, here is the result of For compositing + Multiply I also tried all blending modes, none looked like Always solid.

The giant wall was just a workaround to get the always solid render to show the whole backplate since the visibility override was showing the video upside down/ split.

As I understand the correct setup should be:

Shadow catcher material with "for compositing" on big plane, corona sun and sky or HDR.

Should I render additional passes?


Ah, sorry for misleading you. For compositing mode is so slow to render, that i never used it, hence my incompetence on how to use it. Anyways, if you render it with black direct visibility override as written in disclaimer and then compose it on your backplate using alpha, you should get the same result as with always solid. I think that you need to save and compose it linearly in order to work correctly, but i can be wrong again :]
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2017-11-06, 18:57:09
Reply #6

lolec

  • Active Users
  • **
  • Posts: 172
    • View Profile
Ok, maybe is the linearly part that I'm missing. Because I'm already using black override and the result is not the same.

There are 2 separate issues.

One is that shadows seem to be different for some reason, that is a problem.

The other problem is that Alpha does not seem to include any reflections/light bounces over shadow catcher, see the bottom right corner, there is no "bleed" into the ground, because the alpha channel does not include any.

I also tried to "recover" those reflections by rendering a reflection pass, but I can't find a pass where I get those reflections, maybe it's a bug ?

I think I'm getting slow results using "always solid" because I'm using that giant wall, but since background override does not work for this video, is there any other option ?

2017-11-06, 19:08:31
Reply #7

lolec

  • Active Users
  • **
  • Posts: 172
    • View Profile
Another problem I have is that using Always Solid makes the alpha unusable, because it's just a big white block.

2017-11-06, 20:01:26
Reply #8

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7296
  • Let's move this topic, shall we?
    • View Profile
    • My Models
Hm, i did some simple test and i couldn't get exactly the same result either, despite comping it linearly. Maybe there's something else to it? Let's wait if this topic will catch some more experienced user's attention.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2017-11-06, 21:56:16
Reply #9

lolec

  • Active Users
  • **
  • Posts: 172
    • View Profile
Hope to catch Ludvik's attention :)

2018-01-04, 11:03:15
Reply #10

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10958
  • Marcin
    • View Profile
What tone mapping settings were you using here? (I mean exposure, highlight compression, etc)

2018-01-05, 12:31:48
Reply #11

faust

  • Primary Certified Instructor
  • Active Users
  • ***
  • Posts: 20
    • View Profile
I've got almost the same issue with ShadowCatcher material, colorful objects affect the plane with ShadowCatcher material applied on it, it's appears only in 'For compositing' mode, shadows in 'Always solid' mode are clean. Another thing is that Shadow amount is not working in 'For compositing' mode