Author Topic: [solved] Network problems on Corona scene  (Read 396 times)

2024-04-02, 19:05:00

bcarnevalli

  • Active Users
  • **
  • Posts: 12
    • View Profile
Hello,

I have an issue that is driving me crazy at the office. Let me try to summarize a bit:

Lately i´ve been using Corona more frequently, my office was focused on vray but now Corona only. But i am having major files accessibilities over my network.

Basically, when i open a Corona scene, right after the "Loading Corona assets" phase, my network turns unaccesible and accessing my folder or saving 3dsmax files is impossible.

I´ve checked everything, hardware related. I even uninstalled a fresh windows on my server. Updated bios, updated drivers. The error windows gave me, from what i researched, is kind of related to windows credentials, but checked that as well and the issue happens only when 3dsmax is open with a Corona scene.

When i convert the whole scene to vray, the issue never happens.

Could NaN errors be related to that? It showed up a while ago, but haven´t noticed lately.

Installed Corona 10 and 12 daily builds, same issues.

I researched an issue on Loading Corona assets a while ago and looks like it changed something after Corona 9 version. Anything related to that?

The only to minimize this issue at the moment, is to unplug ethernet cable from server an connect it again. Someting is changed over the network and i am able to save the file at least.

Any ideas??


« Last Edit: 2024-04-09, 18:24:59 by maru »

2024-04-04, 14:27:08
Reply #1

Avi

  • Corona Team
  • Active Users
  • ****
  • Posts: 505
    • View Profile
I can recommend some general troubleshooting steps that might help.

1. Disable any antivirus software you are using on all PCs (including Windows Defender and Firewall) temporarily to check if the issue is related to this software. You can then turn it back on if it doesn't solve the problem.

2. Add custom inbound/outbound rules in Windows Firewall to allow the necessary network traffic for Corona and 3ds Max. Refer to the guide https://support.chaos.com/hc/en-us/articles/4528128298257-Creating-custom-inbound-and-outbound-rules-for-the-DR-Server-application

3. Disable IPv6 on your network adapters. Follow the instructions in the provided link (https://medium.com/@JockDaRock/disabling-ipv6-on-network-adapter-windows-10-5fad010bca75) to disable IPv6 on your Windows 10 machines.

4. Make sure you have network discovery enabled - https://www.isunshare.com/windows-10/turn-on-or-off-network-discovery-in-windows-10.html

5. Check if you are using the latest version of 3ds Max and Corona which is 3ds Max 2024.2 and Corona 11 HF 1 at present.

6. Check the Windows Services list and ensure that "Function Discovery Provider Host" and "Function Discovery Resource Publication" are started and set to automatic start. Steps are as follows:

Press the Windows key + R to open the Run dialog box.
Type "services.msc" and press Enter to open the Services window.
Scroll down and locate the "Function Discovery Provider Host" service.
Double-click on the service to open its properties.
In the "Startup type" dropdown menu, select "Automatic" if it's not already set to that.
If the service is not running, click on the "Start" button to start it.
Click "Apply" and then "OK" to save the changes.
Repeat steps 3-7 for the "Function Discovery Resource Publication" service.


If the issue persists then feel free to start a ticket with us here: https://support.chaos.com/hc/en-us/requests/new
Arpit Pandey | chaos-corona.com
3D Support Specialist - Corona | contact us

2024-04-05, 21:24:11
Reply #2

bcarnevalli

  • Active Users
  • **
  • Posts: 12
    • View Profile
I appreciate the reply.

I have already tried a few of these suggestions and others that you mentioned, but none oft hem worked.

The only way to attenuate is reboot my server, everytime i have a new scene open and when it passes the Corona Loading phase. But this is not healthy.

Tks!

2024-04-09, 02:19:23
Reply #3

bcarnevalli

  • Active Users
  • **
  • Posts: 12
    • View Profile
I can recommend some general troubleshooting steps that might help.

1. Disable any antivirus software you are using on all PCs (including Windows Defender and Firewall) temporarily to check if the issue is related to this software. You can then turn it back on if it doesn't solve the problem.

2. Add custom inbound/outbound rules in Windows Firewall to allow the necessary network traffic for Corona and 3ds Max. Refer to the guide https://support.chaos.com/hc/en-us/articles/4528128298257-Creating-custom-inbound-and-outbound-rules-for-the-DR-Server-application

3. Disable IPv6 on your network adapters. Follow the instructions in the provided link (https://medium.com/@JockDaRock/disabling-ipv6-on-network-adapter-windows-10-5fad010bca75) to disable IPv6 on your Windows 10 machines.

4. Make sure you have network discovery enabled - https://www.isunshare.com/windows-10/turn-on-or-off-network-discovery-in-windows-10.html

5. Check if you are using the latest version of 3ds Max and Corona which is 3ds Max 2024.2 and Corona 11 HF 1 at present.

6. Check the Windows Services list and ensure that "Function Discovery Provider Host" and "Function Discovery Resource Publication" are started and set to automatic start. Steps are as follows:

Press the Windows key + R to open the Run dialog box.
Type "services.msc" and press Enter to open the Services window.
Scroll down and locate the "Function Discovery Provider Host" service.
Double-click on the service to open its properties.
In the "Startup type" dropdown menu, select "Automatic" if it's not already set to that.
If the service is not running, click on the "Start" button to start it.
Click "Apply" and then "OK" to save the changes.
Repeat steps 3-7 for the "Function Discovery Resource Publication" service.


If the issue persists then feel free to start a ticket with us here: https://support.chaos.com/hc/en-us/requests/new

Looks like this really strange behavior is caused by a faulty storage ssd at my 3d assets folder. I have changed to a new storage and it works properly and gave the ssd a format. So far no problems.

2024-04-09, 14:19:17
Reply #4

Avi

  • Corona Team
  • Active Users
  • ****
  • Posts: 505
    • View Profile
Glad that you were able to figure out the issue. Feel free to contact us again if you need any further help.
Arpit Pandey | chaos-corona.com
3D Support Specialist - Corona | contact us