Author Topic: Corona material scale/units?  (Read 716 times)

2021-06-29, 10:34:26

EmilieJuul

  • Active Users
  • **
  • Posts: 6
    • View Profile
Hello,

I am pretty new at using Corona, and I have a problem with the scale of my materials. When I assign a material from the Corona Material Library it appears to be waaaay to large on the object. When I then open the material editor and change the size of the bitmap, from ie. 4000 mm to 7 mm it looks much more correct. However, that means I have to change several parameters and cannot use the materials as they are in the library.

I have tried using a model imported from Revit, and also made a new inside 3ds Max - both have the problem. If I measure an objects dimensions, it has the size that I expect it to have, so the scale of the model seems to be correct.

I have enabled 'Use real-world scale' if that matters and have also tried with it disabled.

I am using 3ds Max 2022 and Corona 6 (Hotfix 2)

I hope someone knows how to fix this :) If you need pictures I can upload some

Best regards Emilie

2021-06-29, 10:49:34
Reply #1

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
Hi. Strange.... there are some things to check:

- Are Max's display unit and system unit both set correct (preferably to the same)?
- Have you tried using x-form on imported geometry? If not, then check if that changes anything.

Hope it helps

2021-06-29, 11:17:40
Reply #2

EmilieJuul

  • Active Users
  • **
  • Posts: 6
    • View Profile
Hi and thank you for answering.

So.. display units and system units are both set to millimeters and Respect System units in Files are enabled.

By using xform do you mean I should use it for scaling the entire model, so that the material scale fits without adjusting the size om bitmaps?

2021-06-29, 11:37:54
Reply #3

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
Hi. Sorry, I didn't write it correct. I meant "Reset X-form". That will reset any transformation information layered in the object - including scale.

One thing to avoid when using Max is scaling on object level. This will give you all sorts of problems, like the one you describe. Since scale on object level is commonly used by CAD users, this often gives problems when importing data into Max.

So always scale on subobject-level in Max, and use the "Reset X-form" utility as the first thing when having problems with scaled objects.

Hope it helps

2021-06-29, 12:03:08
Reply #4

EmilieJuul

  • Active Users
  • **
  • Posts: 6
    • View Profile
Thank you for explaining :) I tried to reset as described, but it does not change the materials.

However, I figured out that if I make ie. a box and enable Real-World Map size in the parameters, the material suddenly fits. BUT I dont know how to apply the same parameter to an imported model and that is probably where something goes wrong with my model. Is there a way to do something like that?

The screenshot attached shows the box on the right and my model on the left with the same corona brick material.


2021-06-29, 12:12:11
Reply #5

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
Hi. You need to apply an UVW-modifier to the object. In this case set it to "Box" and "Real World Scale" and rotate and move the UVW-gizmo till it fits.

Hope it helps

2021-06-30, 10:37:47
Reply #6

EmilieJuul

  • Active Users
  • **
  • Posts: 6
    • View Profile
Thank you so much, this solved it :)