Author Topic: Motion blur for VolumeGrids calculated incorrectly...  (Read 1575 times)

2020-06-08, 23:17:26

Njen

  • Active Users
  • **
  • Posts: 556
    • View Profile
    • Cyan Eyed
I have a scene that has moving geo, and I have animated the camera to move along with it, so the relative motion blur is almost non-existent, which is correct.

I have a vdb smoke sim that is simmed in world space, so the vdb grid is not linked to anything, and also tracks with the objects and camera. But when I render, the vdb appears to have motion blur that is not relative to the camera (first attached image).

To confirm this, I deleted all keys on the camera, and did another render. Now all of the geo is blurred because the camera isn't moving any more (which is correct), but the vdb has no motion blur, but it should, as it is moving through world space at the same speed as the geo (incorrect), which is basically the opposite of the previous image (second attached image).

2020-06-09, 15:05:16
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10881
  • Marcin
    • View Profile

2020-06-09, 22:30:07
Reply #2

Njen

  • Active Users
  • **
  • Posts: 556
    • View Profile
    • Cyan Eyed
I realised I produced these two renders with with Motion blur turned off, which actually now makes sense for a sim produced in world space. So as far as my original issue goes, please set that as user error.

However, before I realised that was user error, I simmed the smoke at the origin in local space with no movement, then linked the volume grid to the geo, so that it moves along with it, and when I did a test render, I got exactly the same results as it it was simmed in world space with no links.

I would actually expect a volume grid that is being translated somehow (linked, animated, etc.) to still have correct transformation blur, even if the motion blur setting on the volume grid option is turned off. But it seems that when motion blur is turned off on the volume object, it kills all forms of movement. If you are chalking this up to 'as designed', then my recommendation for a feature request would be to add an option (a checkbox?) to allow object transformation blur, even if the velocity blur is turned off.