Author Topic: Chaos Scatters heavily affecting viewport FPS  (Read 5126 times)

2022-11-10, 19:37:37

Ink Visual

  • Active Users
  • **
  • Posts: 170
    • View Profile
Hi all,
I don't think I've seen any post related to this issue.

We recently produce more animations, so previewing cameras movement in the viewport became very important element of production.
Our scene is split into many Xrefs, that made us realize that whenever Landscape Xref is loaded, problems arise.

We managed to narrow down the issue to Chaos Scatters. When scatters are enabled, (doesn't matter in what display mode) viewport playback performance drops significantly. From 50-60fps to around 5fps.
(please note viewport navigation is fine, it's about timeline scrubbing and playing viewport animation with "/" button)

When scatters are removed from the scene, all is back to normal.

Now here are some additional findings:
-annoyingly hiding scatters layer doesn't help, changing visibility to dot, point cloud or even "none" doesn't help.
-in order to bring back high fps, scatters need to be either removed from the scene completely, or disabled in the scatter lister.
-we are certain this is not just one of the scatters causing issues. Gradually deleting some of them helps (as per screenshot, we have more than 20 in file), so the more scatters we have the worse the issue is, 2 scatters will be ok, 10 will already affect fps heavily. etc
-fun fact, having Chaos Scatter Lister window open, again kills fps from 50fps to 5fps (even with scatters disabled).
-some screenshots for reference of fps values while scatters are disabled/enabled etc.

Can this be looked at?
We can send sample scene for tests if needed.

Thanks!



2022-11-11, 09:14:14
Reply #1

rowmanns

  • Former Corona Team Member
  • Active Users
  • **
  • Posts: 1892
  • Corona for 3ds Max QA Team
    • View Profile
Hi,

Thanks for reporting this, I think we have this reported internally already.

Would you still be able to provide your scene so I can use it for testing any fix when our dev team looks into this?

There is a link in my signature to our dropzone

Thanks!

Rowan

(Internal ID=989621917)
Please read this before reporting bugs: How to report issues to us!
Send me your scene!

2022-11-11, 12:12:44
Reply #2

Ink Visual

  • Active Users
  • **
  • Posts: 170
    • View Profile
Hi Rowan, thanks.

I just uploaded the file:
Submission ID# 5MGX-FP4B

Btw, we use Corona 8.2, Max 2022.
Cheers

2023-07-20, 16:20:13
Reply #3

Ink Visual

  • Active Users
  • **
  • Posts: 170
    • View Profile
Hi,
Just bumping this one up. Would be great if this could be improved in v10.

It's really hard to work on animating cameras if viewport has 5FPS, and it bacame a real pain in our recent projects.
Disabling Chaos Scatters is not always an option, often we have them as a part of an xref, so in order to improve viewport performance in master file, an xref has to be opened and scatters disabled there....

Can we expect that team will have a chance to look at it in the new release?

2023-07-20, 16:57:27
Reply #4

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 8897
  • Let's move this topic, shall we?
    • View Profile
    • My Models
Did you try to disable update automatically option in scatter's viewport display rollout? Maybe that could help somehow with performance?
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2023-07-20, 23:36:54
Reply #5

Ink Visual

  • Active Users
  • **
  • Posts: 170
    • View Profile
Did you try to disable update automatically option in scatter's viewport display rollout? Maybe that could help somehow with performance?

Hi Romullus, yes just tried this, not a tiny difference in performace, just as bad as with autoupdate.
I did another test, added scatter with 50000 boxes scattered on the simple plane. This scene with highpoly models, 10mln Verts, is playing at 20FPS without scatter.
After adding the box scatter it drops down to 10FPS. Even if I hide scatter, it remains at 10FPS, only disabling or removing scatter brings back 20FPS performance.

Remember that I have flexibility to disable/enable scatters only if they are physically in the scene. If they are xrefed, there's nothing that I can do to improve performance rather than disabling xref.
Scatters are rarely xrefed on their own, usually they are part of landscape/context file, with all the paving and other elemnts that are essential to be visible in the viewport while animating cameras.
Real pain to deal with.


2023-09-07, 13:39:36
Reply #6

Ink Visual

  • Active Users
  • **
  • Posts: 170
    • View Profile
Bumping topic up for v11 since I've seen there are some new features being added to scatter in daily builds.
Would be great to resolve the performance issues of the existing features if possible.

2023-09-29, 15:39:18
Reply #7

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12828
  • Marcin
    • View Profile
This is on the Scatter team's todo list.
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us

2023-10-03, 10:37:43
Reply #8

Ink Visual

  • Active Users
  • **
  • Posts: 170
    • View Profile
Thanks Maru, happy to hear that!

2024-04-01, 13:55:22
Reply #9

Ink Visual

  • Active Users
  • **
  • Posts: 170
    • View Profile
Hi Maru,
Hi, just bumping the thread up.
Was this fixed in latest Corona releases by any chance?
We're still on Corona 9 but are hoping to upgrade to 11 soon if the issues with viewport performance have been fixed?

2024-04-23, 10:57:18
Reply #10

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12828
  • Marcin
    • View Profile
Yes, there were multiple performance-related fixes between Corona 9 and 11. I have the same suggestion as in the other thread:

Please update to Corona 11 Hotfix 2 - https://corona-renderer.com/download
Then test your case, and if you are still observing any issue, submit a new ticket at https://support.chaos.com/hc/en-us/requests/new
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us