Author Topic: 3DS max lagging  (Read 1255 times)

2021-04-07, 09:35:01

simplesteps

  • Active Users
  • **
  • Posts: 6
    • View Profile
Hy guys I have a problem that was probably already discussed but can't find it in the forum. My viewport is lagging big time when my scene becomes a little bit more complex and especially when I turn forestpack on some splines. I have a 32core 3,6Ghz CPU and 128GB of RAM and a 2080TI 11GB graphics card so I don't think the problem is my machine. Do you have some suggestions how to solve the issue? Maybe some plugin or something similar that can manage my textures or something like that?

Thanks in advance

2021-04-07, 17:45:00
Reply #1

hurrycat

  • Users
  • *
  • Posts: 4
    • View Profile
3ds Max 2020 had also started lagging on me after importing a lot of props meshes / plants, and having probably hundreds of materials in the slate editor.
I tried the following things, and now everything is back to speed. I don't know what exactly worked, so you can try them by yourself:

1.Use Cleaner Script.
2.Move everything to a new Max file.
3.Reset 3ds Max user preference settings to default.
4.Move to 3ds Max 2021.

Hope it helps!

2021-04-08, 04:03:04
Reply #2

Avi

  • Corona Team
  • Active Users
  • ****
  • Posts: 116
    • View Profile
Hi,

The viewport lag in 3dsmax could be due to the following reasons:

1. Outdated graphic card driver. Make sure your video card drivers are upto date.
2. If your scene has a lot of objects with same material, try attaching them.
3. If you are using Forest pack to scatter some complex geometries in your scene, you can use the different display modes such as proxy or point cloud to simplify your scene in viewport.
4. You can also try switching 3dsmax display driver to Direct3D9.

Regards,
Avi


2021-06-06, 11:07:33
Reply #3

simplesteps

  • Active Users
  • **
  • Posts: 6
    • View Profile
Tried everything but max is still lagging when my file gets bigger. Switched to max2022 but still no help. Please someone help

2021-06-07, 00:13:22
Reply #4

Bormax

  • Active Users
  • **
  • Posts: 533
    • View Profile
Hi
I have had a problem with lagging different versions of Max. Check this out, maybe you have the same kind of problem as I had
https://forum.corona-renderer.com/index.php?topic=32757.msg183221#msg183221

2021-06-08, 09:24:05
Reply #5

wilbertvandenbroek

  • Active Users
  • **
  • Posts: 423
    • View Profile
Do you have screens of what exactly you are working with? I once had a scene froze up when dragging the timeslider and the slate editor open. A custom material library open in slate was the reason.

2021-06-08, 10:54:47
Reply #6

pokoy

  • Active Users
  • **
  • Posts: 1628
    • View Profile
Some thoughts:
- Using (multiple) Distance Maps with either many objects or heavy geometry can result is slower scene performance if the material editor is open and is displaying these maps or materials using them
- World space modifiers on many objects can slow down a scene due to mesh data being transferred forth and back
- In general, Slate editor and browser both are mostly slower compared to the legacy material editor and browser, closing it may help
- Try to hide the ribbon toolbar within Max UI. It can slow down Max, and for some users, bad viewport performance improves if you reset it: right click > Ribbon configuration > reset Ribbon to default
- Check if your scene has an excessive number of animation layers or empty tracks - some cleaner scripts can take care of these. In some cases, scenes tend to introduce crazy number of tracks for some reason, which bloats file sizes and affects performance
- are you using lots of 3rd party assets or geometry produced by plugins? Make sure to inspect these, maybe they are the culprit?

Have you tried to identify the source of the slowdown?

2021-06-08, 11:02:00
Reply #7

wilbertvandenbroek

  • Active Users
  • **
  • Posts: 423
    • View Profile
The animation tracks tip from Pokoy is a good one, had this same issue slowing down even simple scenes. With Forensic from sini software it was solved.

2021-06-08, 11:34:13
Reply #8

Okmijun

  • Active Users
  • **
  • Posts: 20
    • View Profile
There are a lot of cleaner scripts, which clean note track, among all garbage....but so far I did not find any script which makes better job than this one note tracks cleaner...
It it is real life saver....

https://3dsky.org/3dmodels/show/remove_note_track_pro_antisifa

If you do not have 3DSky account, here is the script


Cheers!



(   

for i = 1 to theMixer.numMaxMixers() do   theMixer.removeMaxMixer 1 false 1
local trackIndex = 1
local m = trackViewNodes[trackIndex]
while (m != undefined) do
(
   ct = numNoteTracks m
   i = 1
   while not  keyboard.escPressed and i <= ct do
   (
      deleteNoteTrack m (getNoteTrack m 1)
      if  (mod i 200)  < 1 then Print (ct-i)
      i = i+1
   )
   trackIndex = trackIndex + 1
   m = trackViewNodes[trackIndex]
)
)


2021-06-08, 13:21:54
Reply #9

pokoy

  • Active Users
  • **
  • Posts: 1628
    • View Profile
Another ones that came to my mind:
- Space Navigator mice are known to cause problems in multiple max versions, if you're using one you might have to use a different driver
- The 'delete ENU folder' voodoo trick. No one knows why but it actually helps for some people

2021-06-08, 15:04:59
Reply #10

Bormax

  • Active Users
  • **
  • Posts: 533
    • View Profile
Another ones that came to my mind:
- Space Navigator mice are known to cause problems in multiple max versions, if you're using one you might have to use a different driver
- The 'delete ENU folder' voodoo trick. No one knows why but it actually helps for some people

My problem was connected with the mouse as well. I had another model of it, but it caused the problem. In my case changing polling rate from 1000hz to 125hz solved this problem with Max and Autocad where I faced the same issue with viewport performance too.

2021-06-08, 15:27:21
Reply #11

lupaz

  • Active Users
  • **
  • Posts: 665
    • View Profile
If you have CAD drawings in your scene that have a huge amount of vertices, that could be it. Try deleting all CAD in your scene.

2021-06-10, 10:06:12
Reply #12

simplesteps

  • Active Users
  • **
  • Posts: 6
    • View Profile
Resolved some of the issues with the turning off the materials library and the material editor and cleaning all the cad drawings from the scene but still not working as i would like since is a 128GB of Ram machine and it is not using even close of the full amount of RAM. Thanks for helping, any more suggestions are highly appreciated.

2021-06-10, 10:31:56
Reply #13

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7240
  • Let's move this topic, shall we?
    • View Profile
    • My Models
AFAIK 3ds Max lagging has nothing to do with the amount of system RAM. Amount of VRAM is much more important here, but your GPU should ba able to handle pretty heavy scenes without much trouble. Anyway, if you have many highrez textures being displayed in the viewport, even 11GB might be not enough. Try to turn off display in viewport feature for some or all textures and see if that helps.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2021-06-10, 10:43:15
Reply #14

pokoy

  • Active Users
  • **
  • Posts: 1628
    • View Profile
Resolved some of the issues with the turning off the materials library and the material editor and cleaning all the cad drawings from the scene but still not working as i would like since is a 128GB of Ram machine and it is not using even close of the full amount of RAM. Thanks for helping, any more suggestions are highly appreciated.

But you are also saying in your first post that Forestpack is causing the most noticeable performance hit... did you check if it gets better when you test what exactly does it?
Many of the steps proposed here might not even help with the problem in your case if it's solely related to FP.