Corona Renderer Forum

General Category => General CG Discussion => Topic started by: patrick.testa on 2021-09-02, 16:56:06

Title: Materials used in scene show no corner brackets in the material editor
Post by: patrick.testa on 2021-09-02, 16:56:06
Hello,
I have this issue since I updated Max 2022 to version 2022.1
When I pick a material from scene in the slate editor, it has no angle brackets, like if it is not assigned and also the button in the editor to select by material is grayed out like if the material is effectively not assigned... but if I assign it to a random object, then the brackets are shown and I can use the "select by material" button again, selecting all the objects that have the material applied.
If I clear the material editor, it forgets everything and does the same issue again... (it does it with any kind of material)
Does anyone have the same problem, or any suggestion?
Thanks in advance!

Patrick
Title: Re: Materials used in scene show no corner brackets in the material editor
Post by: Ink Visual on 2021-09-02, 17:39:20
I do have exactly the same issue!
Wasn't sure whether it's Max 2022 related or Corona 7 as I updated both at the same time.
Title: Re: Materials used in scene show no corner brackets in the material editor
Post by: patrick.testa on 2021-09-02, 17:56:12
I've tried with  scanline renderer and it does the same...
But now I noticed that the brackets are missing only from the first parent node of the material, while the children appear correctly.
Unfortunately, that doesn't help me much, because sometimes I assign for example a multi-sub material or a Corona layered material to an object and only one of its children material to another object. So, if I use the "select by material" button, I'm not 100% sure that I'm selecting exactly what I want...
Title: Re: Materials used in scene show no corner brackets in the material editor
Post by: pokoy on 2021-09-02, 18:47:18
It's a Max bug introduced in one of the PUs. One way to get them displayed is minimize the material editor and maximize again, but yeah, it's tedious.
Reporting to Autodesk is the only option for now...
Title: Re: Materials used in scene show no corner brackets in the material editor
Post by: patrick.testa on 2021-09-03, 11:04:58
Thank you very much pokoy!! It might be tedious but it's a lifesaver for the moment!
I've been using 3dsMax since version 1 and I think I never used the minimize button on material editor... I always open and close it :)
Title: Re: Materials used in scene show no corner brackets in the material editor
Post by: pokoy on 2021-09-03, 12:29:45
Maybe there's a maxscript command to redraw state's UI, that way one could map a macroscript to a hotkey.
Title: Re: Materials used in scene show no corner brackets in the material editor
Post by: romullus on 2021-09-03, 14:22:47
The same issue is with max's toolbars - sometimes its icons are just missing and you need to minimize/maximize max to show them again, or hover the mouse over them, or open and close material editor... It started to happening in max 2016, i can't believe that autodesk didn't manage to fix this to this day.
Title: Re: Materials used in scene show no corner brackets in the material editor
Post by: pokoy on 2021-09-03, 18:06:02
I think that's something else - the general UI hasn't been a problem since a few years, for me anyway, I think they got this sorted at some point.
The mat-ed problem described here is really just the active material indicator, and I think it's even only happening in Slate, not sure though.