Author Topic: Ugly highlights and shadows after render  (Read 1678 times)

2018-05-11, 09:11:38

robertkollar

  • Active Users
  • **
  • Posts: 11
    • View Profile
I have a scene and after I create the render with the corona VFB the highlights and shadows on the background plane look worse then
when I create a render with the interactive render with a max passes of 25.
It looks like there are gradients of different shades of greys and lighter patches.
Im wondering if something has to be adjusted in render settings or maybe
I am doing something wrong or this is the way it should look. I tried to clean it up with photoshop after but still does not look nice.
I look at some tutorials and all suggested not to make adjustments in render settings because the default settings are fine.
The only adjustment I made is noise level limit  to 3, and denoiseing to full, and denoise amount to 1.
I uploaded two files from the 2 renders to show the difference.


2018-05-11, 09:21:16
Reply #1

Nekrobul

  • Primary Certified Instructor
  • Active Users
  • ***
  • Posts: 1026
    • View Profile
There are two options.

-You might have uploaded same images

-Difference is imaginary

I added this two images in photoshop with difference blending and recived this.

UPD - there is option 3, iam blind sorry.

May be it is VFB postprocesing? Do you have bloom enabled?

There is one more interesting thing, reflective caustics from the mouse is almost missing on final image comparing to interactive. Have you tweaked sample intensity?

« Last Edit: 2018-05-11, 09:31:10 by Nekrobul »
---------------------------------------------------------------
https://www.blackbellstudio.com/
https://www.behance.net/blackbell3d
CEO at "Blackbell Studio"

2018-05-11, 10:46:16
Reply #2

robertkollar

  • Active Users
  • **
  • Posts: 11
    • View Profile
Thank you for the reply.
I am talking about the left part of the image where its empty.
The images I uploaded are different, one is interactive render 25 passes and
the other is VFB render with 35 passes 3% noise.
The VFB render is not so smooth, you can see like gradients
and each one is getting darker as you look up towards top of the image.
Its more noticeable at the top part of the image above where I typed VFB.
As you look upwards as the image darkens.
Im not sure if its supposed to be like this, maybe it is, only it does not look nice.
But in the interactive render the transitions from lighter to darker is so much more
smoother, barley noticeable compared to the VFB.
I created in photoshop a comparison with the 2 right next to each other. Only the left side of the 2 images
and I painted over with a blue brush where each different transition begins.
I don't have bloom and glare enabled and have not touched sample intensity, I don't know where it is in corona or what it does.

2018-05-11, 11:07:08
Reply #3

twcg

  • Active Users
  • **
  • Posts: 62
    • View Profile
I cranked the images up a bit and now it becomes clear that the denoising in the final render introduced some banding...
often a little additional noise is used to reduce banding artifacts in 8-Bit images

some options:

1. decrease the denoise-amount to leave some noise in the background to reduce banding
2. add a "beauty" render element with denoising set to 0 and mix them in the post
2. save as 16-Bit Half or 32-Bit Float EXR and dither in the post when converting to 8-Bit

2018-05-11, 11:18:49
Reply #4

robertkollar

  • Active Users
  • **
  • Posts: 11
    • View Profile
Yes that’s it!
So it’s called banding.
I’m sorry but I didn’t know that and
that is why was difficult to explain.
So the only way to reduce it is the
3 options you explained?
Thank you very much for the help!

2018-05-11, 11:28:01
Reply #5

twcg

  • Active Users
  • **
  • Posts: 62
    • View Profile
you can try to add some noise back to the final render... not sure how this will work out...

e.g. https://www.slrlounge.com/remove-banding-photoshop/

2018-05-11, 11:59:51
Reply #6

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10956
  • Marcin
    • View Profile
Are you using denoising here?
If so, it is known to add banding in smooth gradient areas, and that is expected. Denoising is basically gaussian blur with some extra magic, and if you just gaussian blur a gradient in PS, you will end up with the same banding.
In case of using denoising the solution would be to disable it or to lower its amount (the interactive one).
Other than that, as the other users suggested, there are some solutions to dealing with banding. (like adding subtle noise)

2018-05-11, 13:48:23
Reply #7

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7291
  • Let's move this topic, shall we?
    • View Profile
    • My Models
If images are not for web, then saving them to 16 bit format, should help to get rid of banding.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2018-05-11, 16:05:23
Reply #8

robertkollar

  • Active Users
  • **
  • Posts: 11
    • View Profile
Thank you for all the replies and suggestions.
I removed full denoising and set denoise level to 4 in render settings.
The banding is gone. Final render looks much better.