Author Topic: SharedShaders - RenderFarm  (Read 4222 times)

2020-11-05, 10:27:36

WorkFlow

  • Active Users
  • **
  • Posts: 105
    • View Profile
Hi all,

we're working with Rebus Renderfarm for almost 2 years now and we're pretty happy.
Support is great, rendertimes are quick and the plugin is well made.

Unfortunately they are not able to render materials set up with shared shaders.
Now I wanted to ask if any of you (or the devs) could tell me if this is a known technical limitation for farms in general and is simply not possible or if there might be another farm that can work with Corona's shared shaders?

Best regards,
Flo
Windows 10, Cinema4D R21.207, Corona 6.0

2020-12-12, 15:36:05
Reply #1

crazybum2

  • Active Users
  • **
  • Posts: 12
    • View Profile
Hi Flo,
Maybe it's too late for an answer but maybe it will be usefull for other people.
I had exactly the same problem I think.
The error message from RebusFarm Quickcheck was : Error Pluginshader corona shared (1040749) are not supported
I didn't have this problem before Corona 6 (c4d).

So after hours of debugging my scene in all the way possible, I found what's going wrong and its easy to solve : some materials from Maxtree Collection (and in your case, maybe from other model collection or selfmade materials) contains Shared Properties, you just have to rebuild your material by replacing original texture in place of all textures named with "texturename(shared)" or "texturename(bitmap)".

To be more accurate, in my case the problem seems to only exist with MAXTREE PlantModel vol016 (I have many others collection and at this point, I do not have Error message with it).

Maybe it's not the solution you expected but in case of rush, you can do this to be able to render with rebus....
Best regards.

CrazyBum2


2020-12-12, 16:18:31
Reply #2

brabus.s

  • Users
  • *
  • Posts: 3
    • View Profile
Hello
I had this problem too. But now, after I have spend hours to resolve this problem, I found a way to avoid this… Open the corona node material window, under the tool menu there is an option to save without shared shaders! And it save a exact  copy of the work but with out any shared shader (it automatically duplicate the necessary shaders…)

2020-12-12, 16:23:49
Reply #3

brabus.s

  • Users
  • *
  • Posts: 3
    • View Profile
Be aware that rebus farm actually also do not support “corona select material“. My solution is to use “corona layered material”.

2021-04-11, 14:29:29
Reply #4

Elias2019

  • Active Users
  • **
  • Posts: 42
    • View Profile
Hi friends,
I still get this pluginshader error on Rebusfarm despite doing all the things you mentioned! Am I missing something? I cannot use Rebusfarm practically...

2021-04-12, 09:45:17
Reply #5

brabus.s

  • Users
  • *
  • Posts: 3
    • View Profile
Hi.
Did you saved the “unshared” scene trough the corona material node editor option “save without shared shaders”?
1. Open corona material node editor.
2. Under the Tools window “Save without shared shaders”.
3. Choose yes to save an exact copy of your scene but without shared shaders
4. Close the actual project
5. Open the project copy you have just saved (it will be renamed “yourprojectname__unshared.c4d” )

With the shared shaders error it always worked for me

2021-04-12, 19:19:11
Reply #6

Elias2019

  • Active Users
  • **
  • Posts: 42
    • View Profile
Thanks man, yeah I exactly did this but I still get those errors! Any ideas? People say that this is a Corona 6 issue also Rebusfarm's instability.

2021-04-13, 09:26:46
Reply #7

mmarcotic

  • Corona Team
  • Active Users
  • ****
  • Posts: 459
  • Jan - C4D QA
    • View Profile
Hello,

the "save without shared shaders" is a legacy feature that we added mostly for internal use (when handling backwards compatibility), and is probably out-of-date. (We already wrote this to devs some while ago).
Unfortunately, the only workaround right now is to duplicate all shaders which are shared - those are shaders, which in the node material editor have several lines coming out of their output. I know it is tedious to do if you have a multitude of materials, but it is unfortunately the only solution at this moment.

Thanks,
Jan
Learn how to report bugs for Corona in C4D here.

2021-04-13, 18:54:13
Reply #8

Elias2019

  • Active Users
  • **
  • Posts: 42
    • View Profile
Hello,

the "save without shared shaders" is a legacy feature that we added mostly for internal use (when handling backwards compatibility), and is probably out-of-date. (We already wrote this to devs some while ago).
Unfortunately, the only workaround right now is to duplicate all shaders which are shared - those are shaders, which in the node material editor have several lines coming out of their output. I know it is tedious to do if you have a multitude of materials, but it is unfortunately the only solution at this moment.

Thanks,
Jan

Hi Jan,
Thanks friend, I did that one too but it doesn't work anymore...

2021-04-30, 09:27:50
Reply #9

indexofrefraction

  • Active Users
  • **
  • Posts: 106
    • View Profile
So the conclusion is?
Shared Shaders do not work on Rebus ?

This would be most annoying
(making them useless for me)


2021-04-30, 09:31:35
Reply #10

WorkFlow

  • Active Users
  • **
  • Posts: 105
    • View Profile
So the conclusion is?
Shared Shaders do not work on Rebus ?

This would be most annoying
(making them useless for me)

I was in contact with them this week again and they said they're working on it - as for now Shared Shaders are not supported.

On the other hand they just added support for Corona Multi and Distance Shaders!
Windows 10, Cinema4D R21.207, Corona 6.0

2021-04-30, 10:09:52
Reply #11

mmarcotic

  • Corona Team
  • Active Users
  • ****
  • Posts: 459
  • Jan - C4D QA
    • View Profile
Hello,

as WorkFlow stated, Rebus developers have blocked this feature internally until they figure out to fix an issue on their end. It is unfortunately out of our hands, so the only thing we can offer is a workaround, as I have stated before.

Thanks for understanding,
Jan
Learn how to report bugs for Corona in C4D here.