Author Topic: Corona Materials Maps Size  (Read 613 times)

2021-05-07, 14:35:33

huda

  • Users
  • *
  • Posts: 2
    • View Profile
Hello
I have a question regarding the sizes of Corona materials maps in 3DS Max.
Whenever I use any corona material the default texture size is 400×400cm (0.25 × 0.25 Tile). So I have to adjust the size for all the maps one by one.

Is there a way for me to set the default material size to 100×100cm (1×1 tile)?

I use 3DS Max 2022
Corona Renderer 6 (Hotfix 2)
My display units are set to metric (cm), and the System units are set to 1cm.

2021-05-07, 15:25:57
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10698
  • Marcin
    • View Profile
The materials are either using the Real World Size option (which has to be enabled for the objects the material is applied to) or Corona Triplanar Maps (where nothing needs to be done).
You can find more info about it here: https://forum.corona-renderer.com/index.php?topic=20616.0
I hope that helps.
If not, please explain what exactly seems to be the problem. Maybe screenshots showing what exactly you are trying to do and what is happening would help.

2021-05-07, 16:16:33
Reply #2

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7013
  • Let's move this topic, shall we?
    • View Profile
    • My Models
You can use Batch Material Editor script to edit properties of multiple materials or maps at once.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2021-05-07, 17:22:15
Reply #3

huda

  • Users
  • *
  • Posts: 2
    • View Profile
The materials are either using the Real World Size option (which has to be enabled for the objects the material is applied to) or Corona Triplanar Maps (where nothing needs to be done).
You can find more info about it here: https://forum.corona-renderer.com/index.php?topic=20616.0
I hope that helps.
If not, please explain what exactly seems to be the problem. Maybe screenshots showing what exactly you are trying to do and what is happening would help.

The problem is the following:
Whenever I add a UVW Map modifier, The texture appears too large. If I check the box "Use Real-World Map Size" Then all UVW options are disabled and I have to adjust the maps on the material slate editor one by one to make them the size I want.

This is frustrating, In the previous versions, the materials came with the real-world option turned off, and the tiling is set to 1×1 by default so I can adjust the UVW map however I want.

In the attached example, the box size is (100×100×64)cm.
« Last Edit: 2021-05-07, 17:34:56 by huda »

2021-05-07, 18:49:10
Reply #4

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7013
  • Let's move this topic, shall we?
    • View Profile
    • My Models
Apply UVW map modifier with real world scale enabled, then add UVW xform modifier on top and adjust the tiling there. There is a solid reason why Corona material library has real-world, or triplanar mapping and it would be much worse without it.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures