Author Topic: IR and VFB not showing same geometry positions with symbols/instances  (Read 1297 times)

2018-05-11, 18:27:58

Ealexander

  • Active Users
  • **
  • Posts: 131
    • View Profile
    • evan alexander
Early transfer test on a file I am building in Vectorworks then moved into Cinema.  Still building, but just wanted to see it quickly.  When I render with the VFB, I get expected results, but when I render with the IR, I get huge geometry shifts.  Yes - the way Vectorworks handles symbols/instances is annoying :)  But I do this all day long and have never seen this, so I don't know what's different in this file.  I'll upload the C4D file.

Windows 10(1709 Build 16299.431) Running Cinema 4D R18(RB197636) and using Corona B1(core 1.7).

Thanks for taking a look!

EDIT: I also just noticed the file size is humongo!  Not sure why it is so big... (450MB). 1526056337_Stairs-EA.c4d.zip

e.
« Last Edit: 2018-05-11, 18:32:41 by Ealexander »

2018-05-12, 13:59:05
Reply #1

Beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 2046
  • Bengamin
    • View Profile
    • Cormats
Thanks for the file, I just took a look and can confirm it renders strangely indeed. Not sure why though. It will take some looking into.

2018-05-14, 17:09:36
Reply #2

Ealexander

  • Active Users
  • **
  • Posts: 131
    • View Profile
    • evan alexander
Thanks - I do realize the object manager layout of this file is a bit squirrelly.  Vectorworks have changed their I/E methods and I am looking for a better solution.  I'm sure that doesn't help in this case, but as I have said, I do this a lot and have never seen this issue.  Thanks!

2018-05-15, 16:51:47
Reply #3

Beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 2046
  • Bengamin
    • View Profile
    • Cormats

2018-05-15, 19:51:03
Reply #4

Ealexander

  • Active Users
  • **
  • Posts: 131
    • View Profile
    • evan alexander
Could you try to use the latest daily? B2 (2018-04-19) and see if the problem remains?
https://drive.google.com/drive/folders/1Kfqwz77XXO6dhroC6HzwEXk9m9pSZuW9

Yes - I will take a look and try it out when I have a chance - I am in the middle of using Corona on various projects, so I don't want to switch midstream, but I have a few computers so I can try that out.

I just discovered the actual issue on another file: When moving from vectorworks to Cinema4D, VW will take all your symbols, put them at 0,0,0 and put them into a hidden null.  It will then distribute instances of your symbols all around the model as needed.  So - what's happening is the IR is showing that hidden geometry at world center when it should be hidden.  If I move the hidden SYMBOL folder way off to the side, all appears as should be.  THis is a stupid way Vectorworks talks to Cinema - but the issue for Corona is that some hidden nulls are still showing in the IR.