Author Topic: V8 - Apple M1  (Read 180 times)

2021-11-25, 01:13:16

frv

  • Active Users
  • **
  • Posts: 52
    • View Profile
Hi,
I notice that rendering on a MacBook Air 16Gb only 4 cores render with a big model with lots of vegetation (6,7Gb swap used). Smaller models render using 8 cores with about 1,6 swap used. Corona render preparing the scene which takes rather long uses only one core. Is this all normal behaviour. Its a pity that only 4 cores are used when you would actually expect more cores at work in a larger model.

Another thing I notice that C4D layers set not to render just render all the same. I have to turn of render for specific geometry using the red dots in the object window.

For the rest it all renders rather fine on my MacBook Air M1. I am hoping for a better iMac soon with much more memory and cores. Modeling and rendering small stuff is very fluent on the MacBook Air M1.

2021-11-25, 10:37:12
Reply #1

jms.lwly

  • Active Users
  • **
  • Posts: 157
    • View Profile
    • jms.lwly studio
I notice that rendering on a MacBook Air 16Gb only 4 cores render with a big model with lots of vegetation (6,7Gb swap used). Smaller models render using 8 cores with about 1,6 swap used. Corona render preparing the scene which takes rather long uses only one core. Is this all normal behaviour. Its a pity that only 4 cores are used when you would actually expect more cores at work in a larger model.

Sounds very odd - the number of cores used shouldn't ever be relative to the scene, unless you're changing settings in the different scenes. When rendering Corona should always max our the cores (literally 100% CPU power unless you've adjusted the settings). It makes sense that the memory used changes per scene as that will link to the complexity of the model, but CPU cores won't.

I would double check your render settings in the complex scene, and reset them to defaults to ensure you don't have something changed.

2021-11-25, 13:32:55
Reply #2

frv

  • Active Users
  • **
  • Posts: 52
    • View Profile
When I set the vegatation to render only 4 cores (350% cpu power) are used and after a while the system stalls because of lack of ram. When I set the vegetation off and only the geometry of the building renders, all cores render as the activity monitor show about 750% cpu power.

I think the efficiency cores do not render when the workload is heavy as apple has it set to work.
« Last Edit: 2021-11-25, 13:36:31 by frv »