Author Topic: Render to texture, inverted AO maps  (Read 1126 times)

2021-01-28, 18:40:44

Remi_Tribia

  • Active Users
  • **
  • Posts: 11
    • View Profile
Hi,

I've been using Flatiron to bake lightmaps and aomaps. So far never had any issues...
Today a colleague is trying to do the same, but the aomaps are inverted (what should be white is black, and vice versa). Same file, same Max version, same parameters, the only difference being the version of corona renderer.

With version 6.1, AO is inverted, with 5.2 AO is correct.

Is there a setting somewhere to change that?
Having to use 5.2 instead of a newer version, because this is broken, is not ideal...

Cheers!

2021-01-28, 19:06:36
Reply #1

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 4040
    • View Profile
Hi, if you mean CoronaAO, then remember you can set the Occluded and Unoccluded colors right there in the map. Could be your colleague has those colors reversed in the map for whatever reason.

(This assumes you mean a CoronaAO map into a Texmap render element, if you mean something else, please describe the set up :) )

2021-01-29, 11:55:52
Reply #2

Remi_Tribia

  • Active Users
  • **
  • Posts: 11
    • View Profile
I know you can change parameters on the CoronaAO map from the material editor. But when baking I'm not using Render Elements I'm using Render To Texture (shortcut 0) with Corona_AO, and you can't modify a lot of parameters, only distance, background, and if denoiser is used on this pass or not. We can't access occluded/unoccluded colors :/



Thanks :)

2021-06-30, 20:47:42
Reply #3

Remi_Tribia

  • Active Users
  • **
  • Posts: 11
    • View Profile
Still happening with Corona 6.2 :/
Nothing has been done to resolve this issue ?
« Last Edit: 2021-06-30, 23:39:32 by Remi_Tribia »

2021-11-24, 18:16:09
Reply #4

Remi_Tribia

  • Active Users
  • **
  • Posts: 11
    • View Profile
Well, now it's version 7 and still happening! AO is inverted and very noisy, and since we have NO control over dark & light colors, we can't fix it by ourselves...
It's FREAKING ANNOYING to have to reinstall v5.2 just to bake AO maps... and then v7 to work on other projects...

2021-11-25, 08:24:08
Reply #5

GeorgeK

  • Corona Team
  • Active Users
  • ****
  • Posts: 601
  • George
    • View Profile
Well, now it's version 7 and still happening! AO is inverted and very noisy, and since we have NO control over dark & light colors, we can't fix it by ourselves...
It's FREAKING ANNOYING to have to reinstall v5.2 just to bake AO maps... and then v7 to work on other projects...

Hi, I believe I was able to reproduce this.
As for the rest of your comments, I will see if we have this request logged and if not I will log it, I hope this helps.

Bug: (Report ID=CRMAX-1145)
« Last Edit: 2021-11-25, 10:10:10 by GeorgeK »
For solutions, troubleshooting, ticket requests please visit - [link]

2021-11-25, 10:09:55
Reply #6

GeorgeK

  • Corona Team
  • Active Users
  • ****
  • Posts: 601
  • George
    • View Profile
Feature request: (Report ID=CRMAX-1146)
For solutions, troubleshooting, ticket requests please visit - [link]

2021-11-25, 11:46:51
Reply #7

Remi_Tribia

  • Active Users
  • **
  • Posts: 11
    • View Profile
Thank you for taking this into account!