Author Topic: Corona VFB images saved with incorrect gamma  (Read 6519 times)

2015-03-09, 22:15:34

borisquezadaa

  • Active Users
  • **
  • Posts: 615
    • View Profile
Corona version: 1.00.01, Maxsdk version: 2014

Build timestamp: Feb 26 2015 11:16:46
Defines: Wide RGB

Fresh installation. Reset Settings applied. Gamma/LUT in max 2,2

Unexplicably images are saved with incorrect gamma. Never happened before daylies or previous versions.

Frame buffer on right,  left  is saved one.

NEWS: If i save using gamma override = 3,2  (curiously 2,2 + 1,0) it saves visually aproximate.
« Last Edit: 2015-03-11, 22:48:14 by borisquezadaa »
What i do with Corona My Corona post of random stuff rendering
WARNING: English.dll still loading...

2015-03-10, 16:52:42
Reply #1

Jpjapers

  • Active Users
  • **
  • Posts: 1480
    • View Profile
try setting your file output gamma to 1.0 by typing fileoutgamma=1.0 into the maxscript listener.

2015-03-10, 17:04:34
Reply #2

borisquezadaa

  • Active Users
  • **
  • Posts: 615
    • View Profile
Thanks. I set fileoutgamma=1.0 and saveit. Same behaviour. VFB image looks normal, saved image looks darker. Like above images.


Screenshot of message opening the file

And a screenshot of CurrentDefaults.Ini

Curiously if i set Fileoutgamma=2.2 it saves relatively fine.

I let the scene for further investigation. Just a corona Sun and sky 3ds Max 2014. Maybe you guys can reproduce it.
« Last Edit: 2015-03-11, 22:49:13 by borisquezadaa »
What i do with Corona My Corona post of random stuff rendering
WARNING: English.dll still loading...

2015-03-11, 10:00:35
Reply #3

cgiout

  • Active Users
  • **
  • Posts: 114
    • View Profile
You are not the only one. I noticed the same behavior. The only way to save as VFB is using CTRL+C.

2015-03-12, 14:26:12
Reply #4

borisquezadaa

  • Active Users
  • **
  • Posts: 615
    • View Profile
Now i see... starting from max 2014 max handles "automatically" the gamma of files. It seems to me that opening a old scene that has a different gamma can change the default value of Output gamma files to another "number" other than 2,2 necessary for corona to behave correctly.

As from max 2014 and above the output gamma only can be accesed via Maxscript, to me running "FileOutGamma=2,2" in the Listener seems to solve the issue.

So to make things clear in oprder to have correct gamma settings in Corona one MUST have:

1.- Enable Gamma/LUT  correction and set it to 2,2

AND

2.-Make shure that Output file gamma are set to 2,2 also.
NOTE: As 3dsmax 2014 and above does not let you acces that value you must double check entering in the Listener "FileOutGamma=2,2".

That part isn't written anywhere.
What i do with Corona My Corona post of random stuff rendering
WARNING: English.dll still loading...