Corona Renderer Forum

Corona Renderer for 3ds Max => [Max] Bug Reporting => [Max] Resolved Bugs => Topic started by: Alessandro on 2015-11-05, 16:04:48

Title: Looooong time building acc structure
Post by: Alessandro on 2015-11-05, 16:04:48
Here a scene with only one object that makes building acc. structure become so slow.
Using BHV full SAH instead of Intel Embree in Acc. structure it run correctly. Tested with 1.3 Oct 16 on Max 2016 and Corona 1.3 RC7 on max 2015
Ondra, you was looking for a scene with this problem, now you have it.

Thx,
Alessandro
Title: Re: Looooong time building acc structure
Post by: maru on 2015-11-05, 16:27:22
Works lightning fast for me in any configuration. Any guidelines? Or should it only happen when DR/BB rendering?
Title: Re: Looooong time building acc structure
Post by: Alessandro on 2015-11-05, 16:55:16
It happens every time. With Intel embree on.
I had several tests, and in only one case it run correctly also with Intel embree, I suppose (I really can't understand the sequence...) when I move from BHV to Intel Embree and retry to render. But if you set Intel Embree, close and re-run Max, it happens. :(
Title: Re: Looooong time building acc structure
Post by: maru on 2015-11-05, 17:03:38
Tried that, restarted few times, nothing bad happens. Max takes about 500mb in RAM. Can you check in task manager if there is any app running in the background on your machine which takes a lot of CPU or other resources?
Title: Re: Looooong time building acc structure
Post by: Alessandro on 2015-11-05, 17:44:54
No other process is involved in the problem.
Later I'll try to restart my WS and test it again, I can't do it now.
Title: Re: Looooong time building acc structure
Post by: maru on 2015-11-05, 17:59:03
Sorry, I am not sure if we already requested this. If the parsing time is long enough, could you please create a minidump file and send it to us?
Here is how to do this:
https://coronarenderer.freshdesk.com/support/solutions/articles/5000524006
>>>2. Reporting Error Messages or freezes

Please do this during the long parsing.
Title: Re: Looooong time building acc structure
Post by: Alessandro on 2015-11-05, 23:23:27
Maru, I've just opened the file and it run like a flash.
But, try this: turn off Lattice modifier and redo the render. Then turn it on again and redo the render.
Here it stop run fast and start the problem with acc. structure.
Title: Re: Looooong time building acc structure
Post by: Nekrobul on 2015-11-06, 10:46:57
Could not replicate. 3ds max 2014 and 2015.

Have you tryed reinstaling 3ds?
Title: Re: Looooong time building acc structure
Post by: maru on 2015-11-06, 17:19:17
OP, are you using in this scene:
-proxies (especially from older versions of Corona)
-3rd party plugins? (for example Itoo)
Title: Re: Looooong time building acc structure
Post by: Ondra on 2016-05-08, 20:16:48
old bug report, cannot reproduce (and embree was upgraded since then ;))