Author Topic: Deleting Multiple Material Tags Crash  (Read 1637 times)

2021-01-24, 19:06:26

BigAl3D

  • Active Users
  • **
  • Posts: 443
    • View Profile
I've run into this crash many times now. Today, I created a quick house floor plan visualization for a friend. Fairly small project. I added a few generic models to fill out the space. There are some C4D native materials mixed in as well. In this scene, I moved the group of objects to the top to make things easier to find (called These Materials). I wanted to delete all the material tags (Corona materials) and just apply one simple material to the parent null using Cubic. I selected all the tags, hit delete and crash. Every time I tried it crashed. I then tried deleting one tag, no problem. I deleted five tags. No problem. I also tried 10 without issue. When I deteted 15 tags, it crashed. I don't think this is a major issue, but shouldn't be happening nonetheless.

This happened with the December and the new January Daily Builds. I have not tried it in v6 stable release. I also have not tried these sequence with a plain C4D scene with no Corona elements.

I will now upload the project file and bug report to the private uploader. The regular uploader either didn't work or was too slow and timed out, at least the Captcha was timing out. I used the Dropbox method. The file is called "Alex Campuzano_Corona 7 Crash" 140MB.
« Last Edit: 2021-01-24, 19:18:13 by BigAl3D »

2021-01-25, 01:20:25
Reply #1

BigAl3D

  • Active Users
  • **
  • Posts: 443
    • View Profile
Sorry about posting in the Max section.

2021-01-25, 16:40:08
Reply #2

mmarcotic

  • Corona Team
  • Active Users
  • ****
  • Posts: 491
  • Jan - C4D QA
    • View Profile
Hey I downloaded your scene and it doesn't crash by just deleting Material Tags (any number of them)
Did this happen with IR running or without?
Can you supply the _BugReport.txt and a minidump?
Can you supply some further info? e.g. exact steps to reproduce, short video, etc.

Thanks,
Jan
« Last Edit: 2021-01-25, 16:54:32 by mmarcotic »
Learn how to report bugs for Corona in C4D here.

2021-01-25, 18:48:28
Reply #3

BigAl3D

  • Active Users
  • **
  • Posts: 443
    • View Profile
Ah, it only happens with either the Interactive Renderer or Interactive Viewport running. The But Report was included in the ZIP file and is the mini-dump the the gobbledy-gook that shows up after a crash? I don't always get that window.

I'm running MacOS Catalina 10.15.7,
Full-speed non-debug version
Build timestamp: Jan 22 2021 18:59:59
Version: 7.0 daily Jan 22 2021
Cinema version: R20.059 CINEMA 4D Studio

2021-01-26, 09:49:20
Reply #4

mmarcotic

  • Corona Team
  • Active Users
  • ****
  • Posts: 491
  • Jan - C4D QA
    • View Profile
if you have a _BugReport, you probably have a minidump as well (they should be in the same folder) - it's a file.
I cannot reproduce this on Windows, I'll have someone try on Mac.

Thanks,
Jan

(Internal ID=630579990)
« Last Edit: 2021-01-26, 11:12:20 by mmarcotic »
Learn how to report bugs for Corona in C4D here.

2021-01-26, 17:55:31
Reply #5

BigAl3D

  • Active Users
  • **
  • Posts: 443
    • View Profile
From the help files:

"Note: Mac's do not generate minidumps, only bugreports are created from Cinema 4D."

2021-01-27, 09:27:12
Reply #6

mmarcotic

  • Corona Team
  • Active Users
  • ****
  • Posts: 491
  • Jan - C4D QA
    • View Profile
Huh, you're right, my closedmindedness only thinks in Win :)
Learn how to report bugs for Corona in C4D here.