Author Topic: Jagged displacement problems  (Read 1106 times)

2019-05-01, 08:47:17

davetwo

  • Active Users
  • **
  • Posts: 168
    • View Profile
I'm trying to deboss some type onto a gloss surface, but I'm getting jagged edges rather than the smooth transition that I'm after.
The image i'm using is 4k, black and white, I've tried 16bit and 8 bit. Rgb and greyscale. Blurring the edges in Photoshop and blurring the edges in the C4D. But the artefacts are still there.

Am I missing something?

2019-05-01, 11:29:37
Reply #1

davetwo

  • Active Users
  • **
  • Posts: 168
    • View Profile
As an update, this seems to be a problem when it's applied to certain geometry. On a flat parametric plane the material displaces fine. But on the object I want to use, the displacement is jagged. Mmmm

2019-05-01, 13:50:12
Reply #2

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7535
  • Let's move this topic, shall we?
    • View Profile
    • My Models
It wouldn't hurt to see some examples...
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2019-06-04, 19:45:46
Reply #3

davetwo

  • Active Users
  • **
  • Posts: 168
    • View Profile
I have the same problem in a new file so - I'm resurrecting this thread.
I've tried testing on different surfaces and with different resolutions and profiles, but without any luck. Pretty crappy jagged displacement on all tests.
Am i missing something? or is this a bug?
Screengrab and test file attached.
Hopefully someone can shed some light on it.

(oh, Daily Build april 15. c4d r20, mac)

2019-06-04, 19:55:30
Reply #4

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7535
  • Let's move this topic, shall we?
    • View Profile
    • My Models
Did you try to lower displacement size in render settings? It seems that you're using default settings, which might be too coarse for such fine displacement, especially in recent builds.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2019-06-05, 08:48:59
Reply #5

davetwo

  • Active Users
  • **
  • Posts: 168
    • View Profile
Aha - i've reduced the displacement screen size from 3px to 1 and that does help a lot actually. Thanks for the info!

2019-06-05, 09:40:25
Reply #6

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7535
  • Let's move this topic, shall we?
    • View Profile
    • My Models
You're welcome!
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures