Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Br0nto

Pages: [1]
1
[C4D] I need help! / Triplanar Setup
« on: 2020-01-03, 23:22:59 »
Hi there,

I'm trying to set up a car paint material with a triplanar noise in the normal map. However, I'm not sure which projection type to use in the texture tag. I thought that having the triplanar map meant it would ignore any uvs or projections, but each projection seems to dictate where the texture is, as if I weren't using a triplanar map at all.

My setup is:

Layered Material
1. Base matte layer (Just color and reflection)
2. Flake layer
   Bump--> Triplanar
      Texture --> Corona Normal
         Texture -->Tiles (This is the true content layer and I have this set to large tiles for ease of testing)
3. Upper shiny reflection layer (Just color and reflection)

Is this setup correct? Do I need to set up my triplanar in a different way? What is the "correct" projection type to use with a triplanar map so that the map works correctly?

Thanks!

2
[C4D] Bug Reporting / Render Nodes Stopping
« on: 2019-11-20, 17:47:36 »
Hi Corona Team,

We're running into a very frustrating issue that has popped up repeatedly over the past few months. We're running Corona Renderer for Cinema 4D, version 4 hotfix 3.

The issue appears in two parts:

1) We start a team render with 2 or 3 nodes running. As soon as we start an additional node, the others drop off and suddenly cease rendering. No error, no warning, just a total stop.

2) We then restart the other nodes, everything seems to be rendering, and we leave for the night. At a random point a few hours later, nodes begin stopping on their own. Same thing, no error, no warnings, only a complete halt to the process. Note that this particular render ended up doing a lot more passes than we intended, but that should have no bearing on the issue.

Here's what the log looks like in every case, regardless of scene, which computer begins the render, or how many nodes we have running:

Quote
2019/11/20 09:19:36  [Corona4D] [tr client] Rendering pass 533
2019/11/20 09:19:51  [Corona4D] [tr client] Rendering pass 534
2019/11/20 09:20:07  [Corona4D] [tr client] Rendering pass 535
2019/11/20 09:20:22  [Corona4D] [tr client] Rendering pass 536
2019/11/20 09:20:27  Service ALEXS-MAC-PRO went offline
2019/11/20 09:20:27  [Corona4D] [tr client] CoronaCore::renderFrame: after render
2019/11/20 09:20:27  [Corona4D] [tr client] Terminating DR slaves
2019/11/20 09:20:27  [Corona4D] [tr client]  - terminating slave handlers
2019/11/20 09:20:27  [Corona4D] [tr client]  - waiting for broadcast thread to finish
2019/11/20 09:20:27  [Corona4D] [tr client]  - clearing slave handlers
2019/11/20 09:20:27  [Corona4D] [tr client] Terminating DR slaves ended
2019/11/20 09:20:27  [Corona4D] [tr client] Rendering took 7878.98 seconds
2019/11/20 09:20:27  [Corona4D] [tr client] Cleaning up
2019/11/20 09:20:27  [Corona4D] [tr client] Terminating DR slaves
2019/11/20 09:20:27  [Corona4D] [tr client]  - terminating slave handlers
2019/11/20 09:20:27  [Corona4D] [tr client]  - waiting for broadcast thread to finish
2019/11/20 09:20:27  [Corona4D] [tr client]  - clearing slave handlers
2019/11/20 09:20:27  [Corona4D] [tr client] Terminating DR slaves ended
2019/11/20 09:20:27  [Corona4D] [tr client] CutCache memory: 123.907 MB
2019/11/20 09:20:27  [Corona4D] [tr client] Unique Primitives: 3910974
2019/11/20 09:20:27  [Corona4D] [tr client] Primitives with instancing: 3910974
2019/11/20 09:20:27  [Corona4D] [tr client] Area lights: 441816
2019/11/20 09:20:27  [Corona4D] [tr client] Geometry groups: 332
2019/11/20 09:20:27  [Corona4D] [tr client] Instances: 332
2019/11/20 09:20:27  [Corona4D] [tr client] Portals: 0
2019/11/20 09:20:27  [Corona4D] [tr client] Area lights: 441816
2019/11/20 09:20:27  [Corona4D] [tr client] Avg samples per pixel: 718.02
2019/11/20 09:20:27  [Corona4D] [tr client] Avg rays per sample: 38.8574
2019/11/20 09:20:27  [Corona4D] [tr client] Rays/s: 7.34272e+06
2019/11/20 09:20:27  [Corona4D] [tr client] Samples/s: 188969
2019/11/20 09:20:27  [Corona4D] [tr client] UHDCache records: 23
2019/11/20 09:20:27  [Corona4D] [tr client] UHDCache records added during viz: 0
2019/11/20 09:20:27  [Corona4D] [tr client] UHDCache rejected %: 98.4674
2019/11/20 09:20:27  [Corona4D] [tr client] Saving + Cleaning up took 0.019 seconds
2019/11/20 09:20:27  [Corona4D] [tr client] CoronaCore::exiting renderFrame
2019/11/20 09:20:27  [Corona4D] [tr client] Rendered 535/0 passes
2019/11/20 09:20:27  Service ALEXS-MAC-PRO went offline
2019/11/20 09:20:33  Peer-to-Peer Statistics:
    > Noahís iMac Download-Speed 39.28 MiB\s (4x)
    > ALEXS-MAC-PRO Download-Speed 44.73 MiB\s (5x)
    > Jeffís Mac Pro Download-Speed 47.63 MiB\s (5x)
    > desktop-t6m005k Download-Speed 73.57 MiB\s (1x)
Peer-to-Peer Statistics End

Some things we've noticed:

-This time, it was the two windows machines that dropped off, apparently right after they lost sight of the pilot machine (ALEXS-MAC-PRO). However, this has happened with macs before. Other nodes on the network continued rendering through the night, including ALEXS-MAC-PRO, which launched the render. We never had this issue before, and I have no idea what would have changed on our network that random machines can't see other machines.

-The additional cause-and-effect of nodes dropping when others are started, with the same log type, imply it isn't just a network issue.

Is there any way this could be a licensing issue? Is there some setting we should look at? This is really cutting into our production time in a dangerous way. Thanks!

3
I'm working on a scene with a car and some low-level volume atmosphere fog. The tricky part is that I have some "faked" headlights (encased in a set of materials to prevent any light from leaking out) that are somehow lighting up the volume fog where I don't want them to.



If I put a plane up against the headlights, they aren't giving off any light. However, as you can see, the volume fog is causing some odd little light specks, almost like dust in the headlight beams. Any suggestions on removing them altogether? I would have thought that the same methods I was using to block the light would prevent any volume fog interaction: I have a non-visible-to-camera black material inside the headlights that stops the light.

4
I'm trying to fake some headlight fog with a series of layered shaders. First, I have a layered material that contains a white diffuse/fresnel opacity shader, with an additional opacity gradient on top to make it fade out as it leaves the headlights. This part works fine:



However, I also want to add a fade just as it touches the road to avoid a hard transition. The trick is that it needs a separate mapping, since the cones are using a cylindrical map and I need to do a flat map to align with the road:



The problem I run into is that I don't know how to combine these two together in a way that merely adds the second alpha fade to the original headlight layered shader. I tried making it a second material tag mixed on top of the first, but that only gave me stuff like this:



Any ideas? Thanks!

5
[C4D] General Discussion / Fading out a sky?
« on: 2018-08-30, 19:51:44 »
I'm attempting to create a day-into-night timelapse scene, and I'm running into an issue trying to get a smooth transition between the Corona sky and a second sky with a starfield light shader.

I currently have the following set of relevant objects:
Sky_Day: A typical sky object with the Corona sky tag on it
Sky_Night_Stars: A sky object with an emissive starfield shader, with a Corona compositing tag that prevents the stars from affecting the GI or cast shadows

The main issue is that I can't find a way to fade out the visibility of the Sky_Day object. A C4d visibility tag doesn't seem to affect it in any way, and while the Corona compositing tag has a "seen by camera" checkbox, that's a very harsh on/off function. Ideally I need to fade it out over a few seconds to cover the sunset period. Turning down intensity and turbidity seems to reduce the sky to a near-invisible level, but it doesn't allow the stars to shine through as I'd hoped.

Any suggestions would be greatly appreciated.

6
[Max] Feature Requests / True Sunsets
« on: 2018-08-29, 21:25:32 »
I would like to suggest some mechanic for true sunsets. As per this thread I'm under the impression that the current simulation does not support the sun being below the horizon. But as a result, there's no ability to make a true sunset. The Corona sky remains lit and the sun is still visible, whereas it would be ideal if there were some way to have the sun dip below the horizon and the Corona sky fade to black. Maybe an extra 5 degrees of angle below the horizon?

Or, alternatively, allow regular lights to affect the Corona sky shader/setup so that you could fake a sun that can go wherever it wants.

7
[Max] I need help! / Sun Below Horizon [C4D]
« on: 2018-08-29, 19:39:01 »
Hi all,

I have a question regarding true day/night cycles in Corona. I used this method to link the Corona sun to the physical sky renderer to get accurate times of day:


However when the sun sinks to the horizon, instead of disappearing and darkness falling, the sun floats along the horizon at an angle of what I can only assume is 0 degrees before rising again on the opposite side of the sky.



When I removed the link and tried it with just the sun, same issue. I know it should be possible since there's a Corona animation showing a rising sun in this thread:

https://forum.corona-renderer.com/index.php?topic=21186.0

I've attached my scene showing the lowest I could get the sun to render, which prevents any sort of true day-into-night animation. Any ideas?


Pages: [1]