Chaos Corona for 3ds Max > [Max] General Discussion

Corona 10/11 - Corona Render Assets loading very slow

<< < (2/12) > >>

maru:
Hi all, thanks for reporting this. Currently, we are not aware of any similar reports, and we haven't noticed such slowdowns in our internal scenes. If possible, please send us any problematic scenes over at https://support.chaos.com/hc/en-us/requests/new
It would be great if you could attach a scene saved with Corona 9 so that we could compare the V9 and V10 times.

I have some additional questions/considerations:
- Are you using iToo plugins in your scenes? (we had some similar reports in the past which were related to iToo)
- Are you loading your scenes and all assets from local drivers or from network drives/gdrive/dropbox?
- Are there many hi-res textures in your scenes? (for example 100 x 8k textures)
- Does lowering all textures resolutions under Viewports Configuration to a super low value like 128px make any difference?

Frood:
Hi Maru,


--- Quote from: maru on 2023-08-10, 14:54:21 ---we are not aware of any similar reports

--- End quote ---


--- Quote from: maru on 2023-08-10, 14:54:21 ---we had some similar reports in the past which were related to iToo

--- End quote ---

:)

I can confirm (equal or) longer loading times with Corona 10, depending on the scene. Tested with 3 standard scenes, mixed results:

Scene A (Some CBitbaps in the scene that I missed to eliminate or have been in Xreffed scenes/objects)
3:18 - Corona 9
5:09 - Corona 10

Scene A (Cbitmaps converted to std Bitmaps)
2:45 - Corona 9
3:12 - Corona 10

Scene B
2:41 - Corona 9
2:51 - Corona 10

Scene C
2:51 - Corona 9
2:53 - Corona 10

Out of core cache has been off, there are Xreffed scenes/objects in all scenes and yes - Itoo stuff as well. Everything loaded via network/UNC, using Max 2023.

Viewport settings should not make any difference since all viewport stuff starts after loading the scene. The time values are those reported by Max in the log, that is: the difference between the #filePreOpen and the #filePostOpen event.

Btw: And again CoronaBitmap making things worse.

Btw2: That more or less persistent "loading Corona assets" message is just some UI issue imho: Corona seems to use the "TempPrompt" of Max (I use it in scripts as well) and it just does not get cleared by some new message, in this case the last queued string just stays there.


Good Luck



Peter A.:
Hi Maru,

Thank you for your reply.

To your notes:
1/ This slowdown is happening with every scene previously saved and rendered with Corona 9 engine.
2/ iTools plugin: No
3/ Scenes and assets loading: Local SSD drive
4/ Textures: less than 100 textures, below 4K resolution
5/ Lowering texture resolution did not help.


--- Quote from: maru on 2023-08-10, 14:54:21 ---Hi all, thanks for reporting this. Currently, we are not aware of any similar reports, and we haven't noticed such slowdowns in our internal scenes. If possible, please send us any problematic scenes over at https://support.chaos.com/hc/en-us/requests/new
It would be great if you could attach a scene saved with Corona 9 so that we could compare the V9 and V10 times.

I have some additional questions/considerations:
- Are you using iToo plugins in your scenes? (we had some similar reports in the past which were related to iToo)
- Are you loading your scenes and all assets from local drivers or from network drives/gdrive/dropbox?
- Are there many hi-res textures in your scenes? (for example 100 x 8k textures)
- Does lowering all textures resolutions under Viewports Configuration to a super low value like 128px make any difference?

--- End quote ---

maru:

--- Quote from: Frood on 2023-08-10, 21:53:17 ---Hi Maru,


--- Quote from: maru on 2023-08-10, 14:54:21 ---we are not aware of any similar reports

--- End quote ---


--- Quote from: maru on 2023-08-10, 14:54:21 ---we had some similar reports in the past which were related to iToo

--- End quote ---

:)

--- End quote ---

Correction: I am not aware of any similar reports regarding Corona 9 vs Corona 10. We did have some reports of slow loading and they were related to iToo, but it was long ago and it was fixed by better Corona<>iToo compatibility.


--- Quote from: Peter A. on 2023-08-11, 11:22:56 ---Hi Maru,

Thank you for your reply.

To your notes:
1/ This slowdown is happening with every scene previously saved and rendered with Corona 9 engine.
2/ iTools plugin: No
3/ Scenes and assets loading: Local SSD drive
4/ Textures: less than 100 textures, below 4K resolution
5/ Lowering texture resolution did not help.

--- End quote ---

Thanks for all the details. Could you please send us a support ticket at https://support.chaos.com/hc/en-us/requests/new and attach a scene if possible?

3dboomerang:
Can we revert a scene back to corona 9 from 10 for the time being? I'm getting extreme waiting times for opening files.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version