Author Topic: Corona Bitmap Color space/RGB primaries not working properly  (Read 160 times)

2024-02-12, 13:53:04

v.p.vlasenko

  • Active Users
  • **
  • Posts: 71
    • View Profile
Or maybe I'm doing something wrong?
Screenshot is attached

Changing RGB primaries in corona bitmap has a subtle, almost unnoticeable effect. 3dsmax bitmap working as expected by selecting color space during load (those settings not affecting corona bitmap).

Latest daily build
« Last Edit: 2024-02-12, 14:13:32 by v.p.vlasenko »

2024-02-12, 14:09:42
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12660
  • Marcin
    • View Profile
I can reproduce this. We will investigate and let you know what is going on...
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us

2024-02-12, 14:14:20
Reply #2

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12660
  • Marcin
    • View Profile
Looks like passing the normal map through a Corona Color Correct mode with gamma correction 2.2 fixes this, but that should not be necessary...
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us

2024-02-12, 14:24:46
Reply #3

v.p.vlasenko

  • Active Users
  • **
  • Posts: 71
    • View Profile
yeah, I tried this as a workaround, but that's an additional step, especially when there are a lot of textures.

2024-02-12, 14:49:06
Reply #4

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12660
  • Marcin
    • View Profile
This is now reported to our devs (Internal ID=1301174543) .
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us