Author Topic: BUG: R21 v5 daliy build (oct15) - UVW randomization modes (Windows 10)  (Read 2027 times)

2019-10-16, 01:39:46

edub

  • Active Users
  • **
  • Posts: 62
    • View Profile
- There seems to be duplicate "Material ID"option.
- Names do not correspond to those mentioned in the daliy build changelog:

Quote
Renamed randomization modes in UVW randomizer:
"Instance" -> "Objects"
"Material ID" -> "Texture tag index"
(!) "Material GID" -> "Material ID"
"Object GID" -> "Object buffer ID"

2019-10-16, 02:28:35
Reply #1

edub

  • Active Users
  • **
  • Posts: 62
    • View Profile
I have a general question about how the UVW Randomization mode "mesh element" is supposed to work. 
I'm not sure if this qualifies for another bug, since I might be misunderstanding the definitions.  If I have the mode set to "objects" then each individual object gets a different UVW mapping. 
With "mesh element" I was expecting this to affect connected polys, within a single object (for example, two separate cubes joined as a single poly mesh) - but currently it seems to behave indentically to "object".
Am I just not getting the definitions right?...  where can I read about this in the documentation?

2019-10-16, 15:24:40
Reply #2

houska

  • Former Corona Team Member
  • Active Users
  • **
  • Posts: 1513
  • Cestmir Houska
    • View Profile
Hi edub and thanks a lot for the report! The strings are indeed a bug and we'll fix them in the next daily.

As for the "mesh element" mode, I think you've got it right... Could you tell us what setup doesn't work as expected?

2019-10-17, 00:24:19
Reply #3

edub

  • Active Users
  • **
  • Posts: 62
    • View Profile
Hi edub and thanks a lot for the report! The strings are indeed a bug and we'll fix them in the next daily.

As for the "mesh element" mode, I think you've got it right... Could you tell us what setup doesn't work as expected?

I just re-tested, and the "mesh element" options seems to work as expected - maybe I did something wrong last time ;)