Author Topic: Renders take longer on black background?  (Read 413 times)

2021-10-22, 12:17:15

dj_buckley

  • Active Users
  • **
  • Posts: 490
    • View Profile
Hi

I've just rendered a scene twice. 

The first one had a HDRI in the Direct Visibility Slot.  The second one was just black in the Direct Visibility slot (HDRI turned off)

The first one took 1 hour and 50 minutes

The second one took 2 hours and 30 minutes

Is this normal?  A 40 minutes increase to render on black?  There were rendered one after the other, so the only thing I can think is a RAM issue as it is a RAM intensive scene?

But I would have expected a speed increase on the black background.

2021-10-22, 13:22:24
Reply #1

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 7355
  • Let's move this topic, shall we?
    • View Profile
    • My Models
I guess you're using noise level as render stop condition, right? That's happening because the difference in how Corona calculates noise for bright and dark backgrounds. It's annoying, but i learned to use pass limit when doing product rendering on solid colour background.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2021-10-22, 17:15:01
Reply #2

dj_buckley

  • Active Users
  • **
  • Posts: 490
    • View Profile
Correct.  And thanks for highlighting.

I normally wouldn't notice as I render overnight, but I had to re-render something this morning and just happened to note the times of the previous render and the new one when I came back to it.

Good to know