Author Topic: Corona Material Library - Appreciation & discussion thread  (Read 22426 times)

2020-08-21, 13:51:50
Reply #120

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
Hi. Already posted this on the daily builds thread, but think this is the right place.

When using the new "Concrete Plates Dirty" I get the "normal map using incorrect gamma" warning. It also looks like there is some serious terminator problems with correct gamma on this material.

Otherwise there are some great new materials.

Thanks :)

2020-08-21, 14:21:24
Reply #121

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 1363
    • View Profile
Hi,

Thanks for reporting this. We will investigate.

Cheers,

Rowan

(Internal ID=552981284)
Please read this before reporting bugs:
How to report issues to us!

2020-08-21, 16:00:53
Reply #122

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10956
  • Marcin
    • View Profile
Could you please update the standalone MatterialLibrary file, please.
The one here is updated: https://www.dropbox.com/sh/mswauuv1afec8am/AAA5OKrd_QujokDM3mxQ7S40a
The on here not yet, but this is acknowledged and will be fixed ASAP: https://coronarenderer.freshdesk.com/support/solutions/articles/12000036778-how-to-install-the-material-library-in-offline-mode-


It is already updated everywhere. Please Ctrl+F5 your browser in case of problems and let us know if anything else would not work as expected.
« Last Edit: 2020-08-21, 17:37:06 by maru »

2020-08-27, 22:47:06
Reply #123

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 1363
    • View Profile
Hi. Already posted this on the daily builds thread, but think this is the right place.

When using the new "Concrete Plates Dirty" I get the "normal map using incorrect gamma" warning. It also looks like there is some serious terminator problems with correct gamma on this material.

Otherwise there are some great new materials.

Thanks :)

Hi,

We have fixed this in v6 RC6. You will need to re-download the material library, either through the installer or the offline file from: https://coronarenderer.freshdesk.com/support/solutions/articles/12000036778

Thanks,

Rowan
Please read this before reporting bugs:
How to report issues to us!

2020-08-28, 17:22:57
Reply #124

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
Thanks. The gamma is correct now, but I think theres something wrong with the normalmap. It gives some shading artifacts (terminator problems?), and when turned down (0,3), there's almost no bump effect. Doesn't look right to me.

Is this intended?

Regards

2020-08-28, 18:03:29
Reply #125

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 10956
  • Marcin
    • View Profile
Thanks. The gamma is correct now, but I think theres something wrong with the normalmap. It gives some shading artifacts (terminator problems?), and when turned down (0,3), there's almost no bump effect. Doesn't look right to me.

Is this intended?

Regards

Thanks a lot, we will look into this, and hopefully it is a quick fix.

2020-09-03, 13:28:09
Reply #126

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
@rowmanns & maru - the problems with the normal map in "Concrete Plates Dirty" is still present in v6.

I did some testing, and found that the problem seems to be, that the normalmap is saved with wrong gamma. If I put the bitmap loader through a Corona Collorcorrect map with gamma set to 0,45, before plugging it into the Corona Normal map, everything works as expected.

So this should be an easy fix ;)

Regards

2020-09-03, 14:07:51
Reply #127

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 1363
    • View Profile
@rowmanns & maru - the problems with the normal map in "Concrete Plates Dirty" is still present in v6.

I did some testing, and found that the problem seems to be, that the normalmap is saved with wrong gamma. If I put the bitmap loader through a Corona Collorcorrect map with gamma set to 0,45, before plugging it into the Corona Normal map, everything works as expected.

So this should be an easy fix ;)

Regards
Hey,

Thank you for your investigation! I will forward this on to our matlib guys and make sure it gets fixed :)

Cheers,

Rowan


EDIT:
We just looked into this again, we think that the RGB level in the Corona Bitmap which contains the normal map is set incorrectly. It is set to 0.5 and should be set to 1, this fixes the issue for me.

Could you try changing this and seeing if it works for you too?

Cheers,

Rowan
« Last Edit: 2020-09-03, 14:26:50 by rowmanns »
Please read this before reporting bugs:
How to report issues to us!

2020-09-03, 17:09:13
Reply #128

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
Yes I did try that, and it didn't fix the issue. I'm quite confident that the normal map is saved with wrong gamma. Test my described solution out, and you'll see it for yourself.

Regards

2020-09-29, 16:39:47
Reply #129

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 1363
    • View Profile
Yes I did try that, and it didn't fix the issue. I'm quite confident that the normal map is saved with wrong gamma. Test my described solution out, and you'll see it for yourself.

Regards
Hi,

This time we really finally fixed the material. You can download the new matlib from the usual places or with the v6 HF1 installer.

Cheers,

Rowan
Please read this before reporting bugs:
How to report issues to us!

2020-09-29, 18:31:24
Reply #130

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile
Thanks. But it looks like the material library is the same? Or maube im looking the wrong place (the daily-builds site)?


2020-09-29, 21:00:03
Reply #132

PROH

  • Active Users
  • **
  • Posts: 1176
    • View Profile

2020-09-30, 11:59:40
Reply #133

rowmanns

  • Corona Team
  • Active Users
  • ****
  • Posts: 1363
    • View Profile
I updated the file in the DB folder, it looks like I forgot to do that yesterday.

Cheers,

Rowan
Please read this before reporting bugs:
How to report issues to us!