Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - pokoy

Pages: [1] 2 3 ... 110
1
[Max] General Discussion / Re: Reducing RAM usage
« on: 2022-01-17, 12:35:55 »
As already mentioned, textures have the biggest impact in my case, too.
Other thing that can help if you're rendering bigger resolutions is to render as few additional channels as you can get away with, e.g. rendering using lightmix will use up more RAM due to the additional separate channels needed versus a single beauty render etc.

2
It might be that you need to install the PUs, 2022 would not work in headless/server mode without license prior to the hotfix (included in later product updates):

https://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2022/ENU/3dsMax-ReleaseNotes/files/3dsMax-ReleaseNotes-3dsmax-2022-0-1-releasenotes-html-html.html

3
The perpetual ENU folder mystery...
FWIW, you could try to reset the UI and see if it helps, or just reset the ribbon UI - this one helps with some quirks with the UI too.

From what I understand, even people at Autodesk don't really know why the ENU folder gets mangled sometimes. Most of the people who worked on the UI and older components are either long gone or work in other teams now so they probably would need time to understand what the code does before they can attempt to fix it. Resources are scarce at Autodesk and UI problems in particular don't get enough attention as long as the 'magic potion' of deleting the ENU folder works.

4
The Shadowcatcher material produces GI according to its color/texture map - which is logical, you want the shadow and surrounding objects to be affected by its GI, otherwise it wouldn't look natural.
You could probably use the Rayswitcher material with the Shadowcatcher nested in its Direct/Visibility slot and a black material in the GI and Reflection slots as a workaround.

5
Unfortunately, max fluids have no API for 3rd parties and so far they've only exposed it to Arnold, which they do to support their product.
Motion blur with changing topology is a different thing, I'd love to see it in Corona but it's not much needed in archviz so who knows if it'll be implemented anyway.

6
This has been request a long time ago multiple times. So far no luck, but it definitely would be useful in some cases.

7
If you happen to use Multitexture map plugin - this one will crash in some situations with Max 2019 and newer. I don't get crashes on newly created maps but older projects will crash when opening the scene or merging objects using that map.

8
Agreed, pretty much perfect, George! Love it.

As an advertiser, I would choose this anytime over the industrialized version, after all it's what advertising is for ;)

9
I got these, too - only once last week out of a blue - and the only explanation I have is that I didn't clear all material editor slots. Since 2021 (or 2020) the material editor is populated with useless max physical materials and they seem to trigger these log errors. These have nothing to do with Corona however.

10
So I tried a really simple setup and it works correctly here, scenes for max 2018 and 2021 attached.
Didn't care for dummies, just a simple car geo with a path constraint with a few tires and the camera linked to it.

Render through the camera, checking motion blur options on and off and you'll see that it works correctly:
- camera and transform motion blur -> tires' rotation is blurred, car is not (correct)
- camera blur only -> everything looks static (correct)
- transform motion blur only -> car and tires are blurred (correct)

Did you enable the correct motion blur options (both have to enabled) in the camera?
Also, are your transform segments set to high enough values? If you have fast transforms or very long exposure you may have to increase the transform segments in the Corona's settings dialog under 'Scene'. Too low values can look weird or miss the transforms entirely, looking like it's not working at all.

11
This should work, it did definitely work for me. Maybe the hierarchy matters?
My setup was:

animated dummy helper > dummy > camera
                                    > dummy > geometry

So both the geometry and the camera were linked to the animated dummy respectively.

If it doesn't work, make sure to set up a simple repro case for support.

Also, something I discovered recently: if you are using distance maps for mapping, these will not animate with object motion blur, only camera blur. So in a setup like yours, if the moving object would use distance map, the textures from the distance map would get motion blur when they actually shouldn't.

12
I have done this in the past and it worked fine, but that was 2, 3 years ago. Maybe there was a bug introduced in the meantime?

13
[Max] I need help! / Re: Layered Material / ID Masks
« on: 2021-10-20, 14:53:42 »
If I remember correctly, the mask render element doesn't pick up individual IDs from layered materials, only from the base mtl, so afaik there's no way to get 'automatic' masks from textures when using the LayeredMtl.

So let's say you Base Mtl has ID1, your Label Mtl (applied with a mask texture) has ID2 - the mask RE will not show ID2 masked accordingly to the texture mask.
Not sure about BlendMtl... you could test this one, but this one is quite finicky with many layers.

14
I am afraid I was unable to reproduce these comparisons successfully, granted I wasn't able to test this on F-Storm just yet, but for Corona-Vray-Arnold-LuxCore bump fidelity pretty much returned the same, with material settings set at 1.5 IOR and 0.5 Roughness.  Would it be possible to share that exact example scene with us?
One situation where this becomes really visible is if you use a bump map on a glass surface - for example a tiled gradient like on old car headlights. I've ran into this a few times, bump becomes 'invisible' if the object is small or camera is farther away. Close to the camera bump works and anything behind the glass is nicely distorted, farther away it looks as if there is no bump at all and the glass surface is clean and even.

15
[Max] I need help! / Re: RAM problem
« on: 2021-10-06, 14:02:01 »
I had problems with Physical materials in some v7 daily builds - refractive Physical Mtls using certain maps would go through the roof eating up RAM and CPU usage went down, quite similar to what is reported here. I have no idea if this is the case for you but maybe there still are some undetected edge cases with Physical Mtl.

For those who see this - what happens if you hide all object using refractive Physical Mtls?

Pages: [1] 2 3 ... 110