Author Topic: Strange background pattern  (Read 318 times)

2024-05-10, 19:32:00

TJF

  • Users
  • *
  • Posts: 4
    • View Profile
Hi all,

Anyone know what's causing this in the empty/sky areas of a render?


2024-05-11, 11:37:04
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12828
  • Marcin
    • View Profile
Hi, is this visible in the VFB while rendering or only after saving the file to some format like jpg?
Are you using some denoiser here?
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us

2024-05-11, 22:05:30
Reply #2

TJF

  • Users
  • *
  • Posts: 4
    • View Profile
I tracked it down to a tonemapping thing.  Denoiser is off, and output files are the same as the interactive render window.

As you can see, depending on the combinations of tone map settings, for example, magenta and saturation, it will manifest. It can be worked around easily I suppose, but I just figured you guys might like to know what happens.







2024-05-11, 23:56:16
Reply #3

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 8897
  • Let's move this topic, shall we?
    • View Profile
    • My Models
It's most likely because of saturation slider. Yours is set way too high. Saturation in Corona VFB is only usable up to 0,05-0,1 not more.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2024-05-12, 01:56:53
Reply #4

TJF

  • Users
  • *
  • Posts: 4
    • View Profile
Ok that seems to be the cause.

The tooltip says the range is - 1 to 1, but it seems like anything remotely near 1 is unusable.  0.2 is about as much as I can adjust it before it gets squirrely. 

Thanks for your time.

2024-05-13, 15:44:51
Reply #5

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12828
  • Marcin
    • View Profile
@TJF in my message above I asked if you were using a denoiser. I was able to reproduce this with interactive rendering, but only when a denoiser is enabled (Render Setup > Performance > Interactive Rendering > Denoising during rendering: NVIDIA or Intel).

The solution is simply to disable the denoiser. I am not an "AI" expert, but my explanation would be that the denoiser adds some tiny artifacts even to plain areas of the image (hallucinations) and increasing saturation makes it more apparent. Unfortunately, both the NVIDIA and the Intel denoiser are developed by companies unrelated to Chaos, so there is nothing we could do to "fix" this.
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us