Author Topic: Corona 4.1 Caustics strange behaviour  (Read 4897 times)

2019-08-19, 23:36:11


  • Active Users
  • **
  • Posts: 109
    • View Profile
Dear Corona-Team / Coronauts,

I hope that someone can help me. I have one study-project, where I try to demonstrate my contemporary architecture geometry in different light conditions.
It consists of many colored glass triangle surfaces on metal frame mounted with some additional polygons slightly self-illuminated (there is no overlapping of course), as ZYFILM panels simulation).
Unfortunately, when I try to use the new reflective caustics solver, it generates with A LOT of noise/overbright pixels. For all pictures below was set and reached noise limit 3%.

The refractive caustics alone has much less noise. Also, when I don't render caustics pass separately, then I have less noise in refractive and reflective.

My settings are:
I  use LightMix to mix my lighting. Albedo is totally OK. There is also no vantablack in scene.
For the day exposure I set Corona Sun+Sky with native multiplier 1.0 and exposure correction to -2.
For evening situation there are three focused spotlights active (1cm diameter LED 10.000 Lumen with directionality set to 0.6) + displays as textures (exposure 0 with some mixpasses lowered)

Glass setting are simple - 0 diffuse / 1 reflect, refl. glossy 0.98 / 0.9 refract. The thickness is 3mm
Self-illuminated polygons - 0 deffuse / 0.5 translucency / 0 reflection / 0 refraction / thin mode is on / texture in self-illumination slot, multiplier is set to 1

(Corona 4.1, 3dsMax 2019, Win 8.1)

I am sincerely grateful for any help.

2019-08-30, 19:20:46
Reply #1


  • Corona Team
  • Active Users
  • ****
  • Posts: 12845
  • Marcin
    • View Profile
1) LightMix should not be used for extreme cases like this (changing day into night, disabling all lights but one) - it can sometimes work in these scenarios, but usually this will result in a lot of noise/fireflies. This is because the rendering is optimized with the standard beauty pass in mind, and hiding/unhiding lights breaks that optimization.
2) You should try the newest daily build, which has various caustics improvements -
Marcin Miodek |
3D Support Team Lead - Corona | contact us

2019-09-01, 15:28:41
Reply #2


  • Active Users
  • **
  • Posts: 109
    • View Profile
Hello Maru,

Thanks a lot for your Answer.

1. I have used the technique, which described Ludvík Koutný in Complete Project - Interior Visualization tutorial. In section 6 (Post processing and LightMix) he says "If you want to get clean LightMix result, then you have to fake it a bit and set up all the lights in the same exposure" After this trick the overall transformation from day to evening or even night or disabling all lights but one gave me really clean results in almost all situations. Maybe I have misunderstood you and you mean that this technique does not work well with enabled caustics only?

2. Thanks, I will also try the new daily build. Hope it helps. Anyway, I'show the results here a bit later

2019-09-02, 15:25:14
Reply #3


  • Administrator
  • Active Users
  • *****
  • Posts: 5575
    • View Profile
It's possible that the LightMix set up would cause issues, as depending on where the lights are, it could mean that Corona has to sample them all equally for caustics now, versus giving more time and processing power to the bright light(s) that will be most responsible for visible caustics. You could try disabling caustics for the light sources that should be contributing less, to let Corona focus on the ones that will be the most important for caustics, to counterbalance that.

It could also just be that some areas of caustics will resolve faster (the ones nearer to the thing casting the caustics, vs. those caustics that are further from the source e.g. the ones on the walls), and this could just mean letting the render run for longer to clean up those more tricky caustics.
Tom Grimes |
Product Manager | contact us