Author Topic: C4D Thinfilm doesn't work anymore with Corona  (Read 513 times)

2022-11-18, 14:29:41

LRNTNVLL

  • Active Users
  • **
  • Posts: 9
    • View Profile
Hello guys,

To make the carpaint of the car in the picture attached I used the C4D Thinfilm texture in a corona 7 shader. It works very well to simulate the real carpaint used on this concept car and very simple to make.
But since the version 8 of Corona, the C4D Thinfilm doesn't react in a same way. Same issue with Corona 9, and I must to reinstall Corona 7 to make new pictures to have the good shader.

Any idea or solution to have the good carpaint with Corona 9 ?

Thank you very much.
Laurent

2022-11-18, 16:19:07
Reply #1

HVB

  • Active Users
  • **
  • Posts: 33
    • View Profile
Did you try using legacy material?

2022-11-18, 20:27:48
Reply #2

LRNTNVLL

  • Active Users
  • **
  • Posts: 9
    • View Profile
Did you try using legacy material?

It was a legacy material. Same issue with physical.

2022-11-25, 00:56:06
Reply #3

LRNTNVLL

  • Active Users
  • **
  • Posts: 9
    • View Profile
Any advice guys ? Chaos guys ?

2022-11-25, 11:32:22
Reply #4

Beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 2883
  • Bengamin
    • View Profile
    • Cormats
Hi there, there does seem to be an issue with the Thin Film shader. If it's not reported already, I will do so. I was having a look at some options and these are my workarounds so far.

1. Scanned material: 555f00prism


2. A Layered mat with the edge colour bumped up and fresnel


3. A layered with a Legacy mat & Fresnel IOR cranked to 999, Glossiness at 69% & a fresnel shader in the the colour texture slot of the reflection channel.
Bengamin Jerrems l chaos-corona.com
Chaos Corona Support Representative l contact us
Corona Uploader l Upload
Portfolio l Click me!

2022-11-25, 17:38:58
Reply #5

Cinemike

  • Active Users
  • **
  • Posts: 945
    • View Profile
Maybe it's just time for an integrated thin film layer in the physical material.

2022-11-25, 19:00:43
Reply #6

burnin

  • Active Users
  • **
  • Posts: 1437
    • View Profile
IDK how you all make it, but to me it seems to behave correctly.

2022-11-28, 13:32:37
Reply #7

Beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 2883
  • Bengamin
    • View Profile
    • Cormats
One more for fun ;)
Bengamin Jerrems l chaos-corona.com
Chaos Corona Support Representative l contact us
Corona Uploader l Upload
Portfolio l Click me!

2022-12-04, 03:48:33
Reply #8

LRNTNVLL

  • Active Users
  • **
  • Posts: 9
    • View Profile
Hi there, there does seem to be an issue with the Thin Film shader. If it's not reported already, I will do so. I was having a look at some options and these are my workarounds so far.

1. Scanned material: 555f00prism


2. A Layered mat with the edge colour bumped up and fresnel


3. A layered with a Legacy mat & Fresnel IOR cranked to 999, Glossiness at 69% & a fresnel shader in the the colour texture slot of the reflection channel.



Thank you very much. I will test them.