Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Frood

Pages: [1] 2 3 ... 122
1
Hi,

the missing line seems to be a Max bug. But the daylight system works and the sun is actually connected. When I create a new daylight system (Max 2023.2.2), the line is missing here as well. I never done it in Max 2023 until now because I have one in the startup scene, created with an older Max version - so I never noticed.

As for "washed out", you are using the tone mapping stack wrongly. Just move photographic exposure on top of the stack and use reasonable photographic settings, matching a daylight situation.


Good Luck




2
Hi,

How come it works like this? The only reason I can think of is that saving is also turned on for the render elements??


Yes, elements have a dedicated setting ("Elements Active" in Render Elements tab, you can switch them on/off at once there). And this is how Max behaves, Corona just uses the Max output.

If you want to be sure that no files are written, use the "Iterative Rendering Mode", see

https://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2019/ENU/3DSMax-Rendering/files/GUID-BE358D30-AB74-4AE3-81DF-0BA3908065C3-htm.html

It's my usual render mode while preparing/testing a scene, however Corona currently violates that mode by (over)writing light cache files - already reported.


Good Luck




3
Hi,

CoronaBitmap uses the "Baked Procedural Map" value, not "Texture Maps" of the viewport configuration.


Good Luck




4
Hi,

If I wanted to do a wall with graffiti, then dirt over the top

You could setup the dirt mask as triplanar node (good for dirt on curved shapes anyway) and tell it to use world mapping.


Good Luck




5
[Max] I need help! / Re: Corona Pattern UV mapping
« on: 2023-01-13, 14:50:04 »
Yes, CoronaBitmap lacks mapping types, but you have Bitmap for it which is supported by Corona :)

That was my point. The use case image is just an extended scenario which comes for free when using global mapping. Basically what's in the scene file is the basic issue - even if not spreading outside the pattern mod area. And even for this case I know of no solution to do it with CoronaBitmap.


Good Luck




6
[Max] I need help! / Re: Corona Pattern UV mapping
« on: 2023-01-13, 14:12:50 »
Yes, I missed to mention decals in the line of "getting complicated or mad or both" but thought about it :)

Anyway I think it's a common use case (and maybe what the OP wanted to do) and you just cannot do it with CoronaBitmap due to the lack of mapping features. Thus my advice to use a standard max bitmap.


Good Luck




7
[Max] I need help! / Re: Corona Pattern UV mapping
« on: 2023-01-13, 13:15:55 »
Then please someone tell me how to achieve this with CoronaBitmap without getting complicated or mad or both. See scene; the goal would be to add a texture that continues even outside the pattern mod seamlessly as shown in the use case image (dirt even spreads across the decal used for the e-car logo).


Good Luck



8
[Max] I need help! / Re: Corona Pattern UV mapping
« on: 2023-01-11, 17:29:36 »
Hi,

try to use a standard max bitmap node and set the mapping to "Planar from World XYZ" (or "Planar from Object XYZ").


Good Luck



9
[Max] Feature Requests / Re: Tonemapping & Maxscript
« on: 2023-01-11, 09:41:00 »
It would be nice if the operators were managed almost more like how render elements are.

This was exactly my suggestion when I once was asked how it should/could look at the maxscript side. Now, everybody who wants to do serious scripting stuff with tone mapping has to write libraries instead.

I don't know if you aware of this one:

https://forum.corona-renderer.com/index.php?topic=36778.msg201269#msg201269

Have not tried/used it yet and it would need some changes to be able to use it for Camera tone mapping as well though. I almost never use global tone mapping so I'd have to modify it anyway.


Good Luck




10
General CG Discussion / Re: [Useful Scripts\Tools]
« on: 2023-01-10, 09:28:59 »
When I start it again it doesn't recognize the macroScript

Looks like a Max bug, it seems to dislike the continuation characters ("\") in the definition. If you remove them, it works.


Good Luck



12
Hi,

no :) Still the same. If you want to change it by script it would be
Code: [Select]
renderers.current.adaptivity_targetError
Get this to make it easier to find out which properties are changed when using the UI:
https://forum.corona-renderer.com/index.php?topic=16571.msg104052#msg104052


Good Luck




13
Hi,

very useful that summary.

Quote
What happens if you submit a/that scene to BB without using the batch render manager?
Not sure how you accomplish this in Max. Always used the batch Render to send camera's to BB.

You just select "Submit To Network Rendering" at "Target" in Render Setup.

In your scene, there is no output defined, and that's exactly the difference and the reason why I could reproduce the issue only with your scene: it lacks the render output. Here is a quick fix without digging deeper. I don't know if you like it because it changes the scene by adding some output. But you can revert it after submission if you call batchRenderMgr.Render() in the script:

Code: [Select]
nameFile = getFilenameFile(maxfilename)
perspCamObj = getnodebyname "PERSP_CAM"
perspNameCam = nameFile + "_" + perspCamObj.name

-- Additionally:
sceneOutput=rendoutputfilename -- save for restoring later
--if sceneOutput=="" do ( rendoutputfilename=maxFilePath + perspNameCam + ".jpg") -- would be reasonable
if sceneOutput=="" do ( rendoutputfilename="doesnotmatter.jpg") -- but this also works, just has to be some valid file extention for output

perspCamBatch = batchRenderMgr.CreateView perspCamObj
perspCamBatch.name = perspNameCam

perspCamBatch.outputFilename = maxFilePath + perspNameCam + ".png"
batchRenderMgr.netRender = true

-- Additionally, if you do not want to leave the ouput changed:
batchRenderMgr.Render()
if sceneOutput=="" do rendoutputfilename="" -- restoring to empty string if no output was defined

Btw. the same happens with scanline renderer scenes so it's just another 3ds Max bug it seems.

Strange thing is, when I create the outputs with script, then go to the batch, open the "output path" dialog and close it again with save, all works fine


Question is: whatever happens here compared to scripting the filename, can it be scripted somehow.


Good Luck




14
You can no longer just run the script without postprocess config file.

Yes, this is a bug and my droplets also don't work anymore. Had to manually convert a bunch of images today. Very annoying. This issue (along with the broken "Reset" feature in CIE) is worth a hotfix.


Good Luck




15
General CG Discussion / Re: Max forcing backup
« on: 2022-12-15, 14:47:38 »
Hi,

maybe scene converter, configured for automatically starting, automatically removing missing assets and with  "Backup Original Files" ticked :) Press "x" type "scene conv.." and check lower left part.


Good Luck




Pages: [1] 2 3 ... 122