Author Topic: Problem with small leaves on bushes  (Read 5451 times)

2015-08-10, 12:39:31

mtanasiewicz

  • Active Users
  • **
  • Posts: 112
    • View Profile
Hi all,

I have a problem, when I render bushes with small leaves, from the distance they appear desaturated. From close ups everything is ok, the bush is green. I tried to lower bitmap filtering in Corona bitmap opacity. I remember that I did have the same problem in Vray with some bushes, but I've never figured it out. Maybe some of You have a clue?

Thank's in advance
« Last Edit: 2015-08-10, 12:45:40 by mtanasiewicz »

2015-08-10, 12:56:14
Reply #1

PROH

  • Active Users
  • **
  • Posts: 1219
    • View Profile
Hi. Have you tried to disable bitmap filtering completely for the opacity channel?

2015-08-10, 12:57:42
Reply #2

mtanasiewicz

  • Active Users
  • **
  • Posts: 112
    • View Profile
Yep, I lowered filtering to 0,0. Nothing has changed

2015-08-10, 13:19:07
Reply #3

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12845
  • Marcin
    • View Profile
You can use CoronaBitmap for the textures (if you are not using it already...) and set filtering to 0. I am not sure if you followed PROH's advice: have you set "texmap filtering" in F10 > performance > devel/experimental to "none"? Another solution is to paint the white area in the diffuse bitmap to green.
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us

2015-08-10, 13:25:50
Reply #4

PROH

  • Active Users
  • **
  • Posts: 1219
    • View Profile
Hi. I don't think we are talking about the same thing. I think you are talking about "blur" amount, but I'm talking about setting filtering to "none" instead of "Pyramidal" or "Summed". Se the attached picture.

PS - my advice is regarding Max's "standard" bitmap loader.

2015-08-10, 13:30:10
Reply #5

mtanasiewicz

  • Active Users
  • **
  • Posts: 112
    • View Profile
But I'm using corona bitmap as opacity map. There isn't any filtering option like in standard bitmap.  I have also tried disabling filtering for opacity maps when I rendered those plants with vray. I also have tried to paint the bitmap to green outside the leaves. Nothing really helped... I'm wondering if it has something to do with the leaf size. The problem only occurs when I use bushes with really small leaves like 0,5-1cm diameter.

2015-08-10, 13:33:29
Reply #6

mtanasiewicz

  • Active Users
  • **
  • Posts: 112
    • View Profile
Allright guys problem solved. The diffuse bitmap was actually a png image with alpha channel. I opened it in PS, flattened and painted the rest of the map to green and now everything is okay.

2015-08-10, 13:57:06
Reply #7

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 8903
  • Let's move this topic, shall we?
    • View Profile
    • My Models
@PROH filtering of opacity maps is disabled globally by default, so usually it's not necessary to turn it off in maps itself.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2015-08-10, 15:50:20
Reply #8

PROH

  • Active Users
  • **
  • Posts: 1219
    • View Profile
aaahhhh... Didn't know that. Thanks for the info :)

2015-08-10, 17:11:08
Reply #9

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12845
  • Marcin
    • View Profile
Confirmed.
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us

2015-08-10, 17:15:44
Reply #10

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 12845
  • Marcin
    • View Profile
Ah, ok, I get it, it woks like this in scanline too. When there is alpha in diffuse, the "background" diffuse color gets displayed. Alpha gets slightly blurred in diffuse channel and it overlaps even if opacity map is perfect. So another fix is to set diffuse color to green.
Marcin Miodek | chaos-corona.com
3D Support Team Lead - Corona | contact us